Glyphs-script-master does not work

Hello !

I’m encountering a problem with the mekkablue Glyphs Script Master… from what I’ve seen when other people use the scripts, dialogue boxes should open when clicking any of the options but it doesn’t work with any of them. The scripts are there, they’re installed, they show up in the Glyphs App but nothing happens when I try to use them.

Any idea of what could be wrong :frowning: ? I’m on macOS Big Sur and Glyphs 3.

Did you installed modules ?
if not, you have to do it from the Plugin Manager

Yes, all the modules are installed !

Do you get any messages in the macro window?

I did get all this :

But I don’t know which part has to do with the script since I’ve been using Glyphs for the past hour…

Your python installation misses some modules. The most important is Pyobjc (see line 3 in the error messages).

What do you see in Preferences > Addons > Python version?

The version is Python 3.9.1 ! also how can I install the missing modules ? They don’t show up in the modules installation section…

Python 3.9.1 (

Then you need to install pyobjc (use pip3 install pyobjc in the terminal). Or use the Glyphs-python as installed form the plugin manager.

Hello again ! I tried to update/install pyobjc but terminal says there’s an issue with the pip version (?)

I’m sorry for asking so many things :frowning: but do you have an idea of what’s wrong ? I can’t find the file I’m supposed to upgrade it from in the library… I don’t know if I’m missing something obvious or not ;;

There is something wrong with your python. Can you reinstall it or just use the one from Glyphs? (install it from the Plugin Manager, restart Glyphs then select it in Preferences > Addons and restart again).

I did reinstall the latest version and it does not work either… and this time nothing appears in the macro panel. I also tried using the Glyphs one and it doesn’t seem to work either.

Did you pick the Glyphs Python in preferences and restart the app? And what exactly does not work? Which script are you trying to run?

Perhaps read through the Extending Glyphs tutorial on the Learn section of this website.

I tried using all the Add-on preferences available if that’s what you’re asking… What doesn’t work as I mentioned above is the dialogue box that’s supposed to show up but doesn’t. And the script I was trying to run was copy layer to layer but since I noticed it wasn’t working I tried running quite a few other ones but as I said, the dialogue box doesn’t appear which basically stops me from using any script.

Can you be more specific what you did?

What is set in Preferences > Addons > Python version? Do you have an entry that contains “(Glyphs)”? Select that restart Glyphs.

Or reinstall your system python as that is clearly broken.

I’m sorry if my explanations aren’t clear enough :frowning: well in the preferences settings I tried both Preferences > Add-ons > Python version > Python 3.9.1 and Python version > Glyphs 3.9.1 (restarting the app each time I changed the preferred add-on) and well, nothing would happen. I also did reinstall Python which is why I’m confused on why it’s not working…

Do you think the issue could be coming from the way I installed the scripts even though they appear in the Scripts category ? Or that it might be coming from Glyphs itself ?

You might need to remove the Glyphs python in the Repository folder and re-install it from the plugin manage. It is sometimes not installed correctly.

Did you get the system python to install pyobjc?

Hi!! Well turns out Python was indeed incorrectly installed, I had tried uninstalling it before but probably hadn’t done it the right way! The dialogue boxes finally work now, thank you so much for your help and sorry for taking your time when it could have been solved way earlier if I had done things properly haha… have a nice day :smiley: