Glyphs won't warn if master is not compatible

I have three masters on my .glyphs file. Masters are compatible and if, let’s say, for example, if I remove a node in one of these three masters, Glyphs warn me (by adding that coloured sign on top of the Glyph window) that these masters are not compatible anymore, so everything is working as expected. I decide to add a new master by duplicating one of my masters. Now, if for example I remove a node in a glyph in this new master, Glyph won’t warn me, it won’t show that the masters are not compatible. What did I do wrong?

You need instances that actually interpolate or add the ‘Enforce Compatibility Check’ custom parameter.

1 Like

But how do I make all instances interpolate? I’ll try that custom parameter. The thing is, I had a ‘light’ master which had 36 units on vertical stems. I decided to draw a thinner master, so I duplicated the light master and started making stems thinner, with 26 units. Is that the right way to add an even thinner master? (I might delete the light master later, because I’ll have a thinner master, but for now I’m keeping it)

The custom parameter is enough. With interpolating instances I meant that you need at least one instance between each master. So if you have masters at 26, 36 and 80, you need instances at 27–35, and 37–79.

1 Like

My masters are at:
Thin: 26

I just added an instance at 30, between 26 and 36 to test. Look what happens:

If I make any changes, they won’t affect instances above 30.

For this parameter to work I need to quit Glyphs and re-start it, right?

Which interpolation value does the third instance have?

The third instance interpolation value is 36.

I deleted some instances now, but the error continues.

When I press control+option+command+n to check masters compatibility, it clearly shows that the thin master is not related to the others.

Can you send me the file?

1 Like

Yes! To which e-mail address?

To support at this domain.

1 Like

File just sent!

That is not an error then. 36 is not an interpolation, because 36 is the value of the master. No need to interpolate, since it is the same as the master.

1 Like

Thank you, Rainer! Sorry for the confusion!

Also, there is this error when I try to export to a variable font:


But my ‘g’ glyph is compatible. This wasn’t happening before I added the new master. What am I doing wrong?

Can you post a screenshot of the g?

1 Like

Yes, here it is:

41 54 21

Ok, just saw it. In the thin master the bottom most node was not the ‘first node’. Just corrected! It’s working now! I usually always notice this kind of error. Sorry for the confusion again, this time. And thank you so much for your patience!