Having trouble installing Word-O-Mat Plugin

I see, when I do it says:
<module ‘vanilla’ from ‘/Users/nicolasdesle/Library/Application Support/Glyphs 3/Scripts/vanilla/init.py’>

I guess it installed then, though the plugin still doesn’t work.

How did you install the plugin?

I finally got it to work.

  • I installed vanilla using the macro window.
  • I then deinstalled the plugin using the plugin manager.
  • I quit the app.
  • Reinstalled the plugin using the plugin manager.
  • Got a warning
    *Failed to clone repository from *
    *https://github.com/schriftgestalt/word-o-mat *
    *to *
    /Users/nicolasdesle/Library/Application Support/Glyphs 3/Repositories/word-o-mat
  • Ignored that warning and just used the plugin

Thanks for support.
Glyphs is a prime example of what software should be.

1 Like

Also having trouble. Got this error via the Plugin Manager:

Screen Shot 2022-08-10 at 5.16.08 PM

Tried going to the GitHub page and received similar error when downloading.

Glyphs 3133 / OS 10.14.5

It appears that GitHub is currently having issues. GitHub is where the plugin is downloaded from. I suspect they should have fixed their issue within a few minutes, probably within the hour.

Ah noted, thanks Florian. Will try again in a bit and see…

I had the same problem a month or two ago. It looks like a repository issue (but i’m not sure).

I just had a look at it and I got the error a few times. But now it works fine. :confounded:

Hmm… tried a few times too, but still seem to be having same issue. Interesting it worked for you eventually.

Can you check if you have any remanence of previous installs in the Repositories and Plugins Folder?

Sorry, missed this. Thx for the reply.

Actually downloaded yesterday from the Plug-in window, and all worked correctly :slight_smile: So whatever it was got straightened out.

1 Like

I’m having this same problem with word-o-mat. (“This plugin needs the vanilla module to be installed for python 2.7.”)

I tried manually importing vanilla and get this error:

Traceback (most recent call last):
  File "<macro panel>", line 1
  File "__init__.py", line 6
    from vanilla.vanillaColorWell import ColorWell
  File "vanillaColorWell.py", line 5
    from AppKit import NSColorWellStyleDefault, NSColorWellStyleMinimal, NSColorWellStyleExpanded
ImportError: cannot import name 'NSColorWellStyleDefault' from 'AppKit._AppKit' (/Users/marksimonson/Library/Application Support/Glyphs 3/Repositories/GlyphsPythonPlugin/Python.framework/Versions/3.9/lib/python3.9/site-packages/AppKit/_AppKit.cpython-39-darwin.so)

I’m running Glyphs 3.2 (3218) on Monterey 13.5.1.

Please remove and re-install the Glyphs Python and vanilla module in the Plugin Manager.