Hebrew Marks not aligning to anchors

When I export my font the Hebrew marks do not align to the anchors. The only thing that fixes this is if I delete all of the features from the Features tab in the Font Info panel (I tried deleting one at a time but it only works when there are no features at all…)
Any ideas as to what can be doing this?
Here’s the .glyphs file: atlas-pro15.zip (124.0 KB) if anyone can take a look.
And here’s an example of how it should work.

Here’s some Hebrew for testing: בּשֱׁחֹ
Thanks very much,
Avraham :slight_smile:

I previously reported a similar issue:

Hey, that is a different issue. :slight_smile: Similar, but different. For me the Compound glyphs are working. All the combinations that do not have a Compound glyph aren’t aligning to the Anchors.

I believe there are two issues here;

  1. related to no Hebrew CCMP as mentioned in my post above.
  2. testing with Indesign Diacritics adjustments as None & Baseline adjustments as shown below proofs something infected with the last one :

here is another comparison example (:

I have a similar problem with composed Hebrew glyphs being ruined during export: Composed Hebrew characters break during export

UPDATE: this happens only on the new Glyphsapp - version 2.3
I exported the file on my other computer that has the previous version (2.2) and it works.
@GeorgSeifert @mekkablue Can you look into this?

Please add the line

languagesystem hebr IWR;

to the Languagesystems. I’ll add that automatically in the next version.


Perfect. Fixed it. Thanks Georg!!

1 Like