Help with figures, they have messed up punctuation

Hi all, first time posting here to get some help. I’ve only been using Glyphs for a few weeks and have bitten off more than I can chew lol

I have followed the tutorial Figures: superscript (superior) and subscript (inferior) figures | Glyphs to get figures into my font and they has messed up the punctuation. I’ve unchecked the export of the figures and re-exported the font hoping that it would revert back to the normal punctuation.

But nothing has reverted, faced with the same issue.

Any ideas?

Edit: Would this be font caching perhaps as I export the font and replace the existing in Apple’s Font book?

What does ‘messed up punctuation’ mean?

Don’t do this. Read this please: Eliminating font cache problems | Glyphs

Thank you, I stopped replacing the fonts and then my last export file worked.

What was happening… the figures were appearing in place of a full stop or a comma.

I’ve reintroduced the figures and they seem to work fine in my test file. In Adobe Illustrator’s Glyph panel, there are glyphs that are not auto-generated. Is this something I need to add in Glyphs3 and map??

Thanks again.

You need to add all precomposed fraction glyphs.

1 Like

Yes, you are testing for glyphs that are not in your font. Two options:

  1. Remove 1/3 and 2/3 from your test file. They are not very relevant as precomposed characters (cannot be typed) and are now better done with the frac/numr/dnom OpenType features anyway. Or…
  2. Choose Glyph > Add Glyphs and enter onethird twothirds, then confirm the dialog.
1 Like

Thank you both.