Help with pixels from illustrator to Glyphs

Hey guys, I’m new to type design and have recently bought Glyphs to try it out.

My workflow includes copying Illustrator to Glyphs as there are certain shapes I find it easier to control in Illustrator. However, as I zoomed it closer I find that some of my paths have moved despite I have adjusted the same pixel on illustrator.

I really do need your expertise to help me with this matter! (Top is illustrator and bottom is glyphs)

In fonts, all coordinates are rounded. That can be disabled if the fonts really has very fine details. But that is not the case with your outlines.

It seems that there is an extra node very close to the end of the white spike. I’m quite certain that is can be removed without changing the shape.

And I wonder what you can do better in Illustrator?

Hi George,

Thanks for the reply and I’m still a little confused is it possible to set up some sort of stream on Zoom? I’m more than happy to pay for your time.

When I delete the nodes it completely changes my shape of my letteroform.

Put the original shape in the background (Path > Selection to Background), then delete the point and then it should be easy to reconstruct the shape.

Right after you pasted from Illustrator, the coordinates are not rounded. If you remove the extra nodes before anything else, the automatic shape will be much better.

Hi George,

Thanks for your reply again.

As you can see I deleted the nodes the and it completely changes the shape.

Also my concern this isn’t just one letter. If I have to repeat, I’m gonna end up repeating for the other letters which may make the typeface look inconsistent.

As you can see this is how the shape looks like in illustrator? I’m not quite clear as in what aspect am I not getting.

Can you send me the .ai file?

Is there an email I can send to?

Apparently, I can’t upload the Ai. file here.

Try zipping the file and post that.

I’ve included the letter N & V.

If you do require more letters do let me know.


V (1.1 MB)

I’m going to repeat some of Georg’s comments, but fonts are typically drawn in a coarse grid, and this kind of approximation is bound to happen when you paste from Illustrator (this is not Glyphs, rather any font editor). The breakage in the outline is most visible when you have a very small line segment like this or you have lots of segments.

Attached is my Glyphs file after cleaning up a bit. You can see that the curves are drawn with fewer nodes.
New Font.glyphs (3.8 KB)

While it’s certainly doable with this resolution setting (we call it UPM: Units Per M) and a good type designer should always revisit their outlines in such a process, a simpler solution that doesn’t involve correction is to increase it to a higher number like 2000 or 3000. You can change that in the Font Info.

1 Like

Hi Tosche,

This is incredibly insightful.

At the moment I’m still trying to get used to drawing with fewer points.

Anyways thanks for your help!.

1 Like

Can I chime in here. It has been my experience that too many nodes are too many nodes. Remember a perfect circle is drawn with only four nodes. I import my fonts from vector images at times, but before I do I delete all un-necessary nodes. This is a case of less is more. I get work created by others and i delete a lot of nodes on their art ( not changing the shapes ) so i don’t have this problem. I hope this reminder helps.Screen Shot 2021-05-14 at 10.19.18 AM Screen Shot 2021-05-14 at 10.23.27 AM


Hi Sketchy,

Sorry for the late reply. Thanks for showing this visually as I’m starting to be able to grasp the idea now. THANK YOUUU!