How to take master out of interpolation range

I want to add a master in a .glyphs file that will not affect the interpolation compatibility. It used to be that you could just put a master into negative axis and it would work… (and at some point it used to be that it would work if you just didn’t create an instance between 2 master). But now it’s changed.

Please see this glyphs file, I have Weight, Width, and Square – Weight and Width should be interpolable, but the Square one should be outside of the interpolation range… how should this be set up now?

I tried 3 configuration

3 axes
(Weight, Width, Square)
Regular 50, 50, 1
Extended 50, 100, 1
Bold 100, 50, 1
Bold Square 100, 50, -1
Bold Extended 100, 100, 1

and then

2 axes
(Weight, Width)
Regular 50, 50
Extended 50, 100
Bold 100, 50
Bold Square 100, -50
Bold Extended 100, 100

and then

2 axes
(Weight, Width)
Regular 50, 50
Extended 50, 100
Bold 100, 50
Bold Square -100, -50
Bold Extended 100, 100

Glyphs file

And it still doesn’t work:

Do I understand correctly that you want to insert a shadow master that will not affect any of your instances? If so, select all your instances and set the “Disable masters” option in all of them.

Yes thanks, but the problem isn’t that the instance is affected, it’s that all the masters become linked to it and then I can’t correctly fix interpolability because the extra master is in the way.

Especially when we’re doing typeface with special cuts that are related but don’t need interpolation.

So I think it makes more sense to be a custom parameter one can add to the Master as well. @GeorgSeifert?

The negative interpolation values should work, but I guess the problem in recent versions is the Variable Font support, which keeps instances with negative values in the design space.

There was a similar thread the other day. I filed it as a feature request, so it is on our list.

Ok I see. What’s do you recommend as the solution right now? We need to keep these masters together in the same file for consistencies sake, but also need to interpolate the other masters.

If you do want to work in the latest app versions, I would still take them apart into different files. What exactly are the consistency issues you are trying to avoid?

Lots of things depending on the glyph or design: metrics, stroke weight, counter size, terminal angles, etc – it’s really handy to be able to flip between masters to check and compare.

As a workaround, or maybe better option, have you considered the Show Italic or Show Next Font plug-ins? Or Mark’s Sync Tabs?

I experience the same problem currently with some font files since the recent update. I used to do it with the -1 hack but that never felt like a robust solution. An option (checkbox, custom parameter) to remove a master from the interpolation axis would be super handy! Thanks for considering.