How to upgrade from Glyphs 2 to Glyphs 3?

I cannot find a way to upgrade to Glyphs 3 from my Glyphs 2 license, eventhough I have tried looked around the new website and it just keeps pointing me back to Glyphs 2 license purchasing!


Hi, I tried the same and got stuck at the EULA page. No way to proceed.

Also, I’ve tried to install Python to use the existing plugins but then Glyphs started to crash and now it won’t open again…

I also installed a plugin and got crashes. Solved it by deleting the Glyphs 3 folder in ~/Library/Application Support

When upgrading glyphs 2 to glyphs 3, do you need to reinstall plugins and scripts previously installed on glyphs 2?

You should have received an email with an upgrade coupon.

Yes, you need to install all plugins again. But the plugin manager should be helping with that.

1 Like

Email not received.

1 Like

Can you check you spam folder? And if it doesn’t arrive till tomorrow, send an email to

Just curious, is Glyph 3 is x86 or ARM based or both?
My guess, Glyph is not an intense application there might not be any noticeable performance drop with Apple M1 and future processor. But it’s good know.

And letterink plug-in is in beta for a long time. Any news on when this plugin could be released

G3 is both.

1 Like

I got the discount code email and purchased the license! Now let’s get to work!

@GeorgSeifert I encountered a big bug when trying to reinstall the plugins. Glyphs3 won’t open if I have those plugins in the Plugins folder. So I deleted those and Glyphs3 open again, but without plugins.
Could you have a quick check on this?

@George_Thomas Letterink is an essential plugin. I understand it’s 3rd party plugin. This plugin would make Glyphs more powerful.

It’s in beta ever since it was announced. They wouldn’t even respond to email. Is there something you could partner with them get the app to release state. This is just a suggestion.

You can ask the LetterInk developer here on the forum: @MartinCetkovsky

@chandra @mekkablue We were waiting for Glyphs 3 to go public before including Letterink for Glyphs 3 in the official package. Please give us some time to update our web and packaging to also include the build for Glyphs 3 as we discovered the release just now. I am not aware of any notice from Glyphs that the public release is going to happen just now, so we are unable to be ready at Day 0. I try to get it out this week, or the next at the latest.

1 Like

from the forum I am seeing G3 is released to public. @GeorgSeifert please confirm

Please release the letterink with ellipse brush as soon as possible

Thank you

No need to confirm, it’s clearly stated on the public web.


How long should I expect to wait for the upgrade email? I haven’t received it yet. (I’ve been checking spam folders, too.)

Same here, no email yet, nothing in the spam folder.

Most upgrade e-mails have been sent out already, but not all. So:

  1. Please also check your spam folder,

  2. make sure you check the e-mail with which you bought the Glyphs 2 license,

  3. some e-mails are still getting sent out, but if yours does not arrive by the end of the day, please let me know, and I will pass your request on to the people who have access to the license database (I don’t).

1 Like