HT Letterspacer - Error and Tabular

Hi there

I use HT Letterspacer and the HT Letterspacer manager. Which is super cool btw.
But in the latest builds (last 2 months) it has started to crash each time I use it.
Does anyone experience the same?

Another question regarding HT Letterspacer/HT Letterspacer Manager: How can I define glyphs to have the same width? like tabular numbers and math glyphs?


Do you get a crash report?

Yes and I’ve submitted quite a lot of them:)

Is the script crashing or the whole app? If the later, what version of Glyphs do you have (the four digit number in the about box)?

The HT letterspacer manager seems to work fine.
But when I apply the script (eweracs - HT Letterspacer for all masters), it crashes.
I use the 3.2 (3227).

Hi Rasmus, happy to hear you’re enjoying HTLS Manager.

Personally, I haven’t encountered issues with the For All Masters script, but I’ll test on the latest build tomorrow.

Concerning tabular numbers: you don’t need to define a fixed width in the manager. For tabular glyphs (.tf, etc.), it takes the current width (or width metrics keys). I advise setting a =600 (or something) for and setting all other tabular figures to

Thanks @SCarewe and @GeorgSeifert
I’ve just submitted a new crash-report now with a few more details. I really hope this gets fixed cause I really loved to use that script.

I see the crashes. Thanks. But it is deep inside Python. So not much I can do.

I had a similar issue that could be fixed and that was changing a list that was changed while looping over it.

I’m not really a Python expert, so it doesn’t really make much sense to me :slight_smile:
but can you pass the appropriate information forward to @SCarewe ?


I’m afraid Georg will know much better what the issue is, I will probably not be able to properly read the bug reports.

Sadly not. I can only review the script code, too.

I just tough about if there could be a bug in my script/setting?
I can’t see any, but could you (@GeorgSeifert and @SCarewe) check and see if there is anything?
Should I simplify it or do anything differently?

# Script, Category, Subcategory, Case, Value, Reference Glyph, Filter

# Letter

# Number
*,Number,Decimal Digit,*,1.3,one,*,

# Punctuation

# Symbol

# Mark

Let me also know, if there is anything you would set differently :slight_smile:

Are you using this config file? Or the interface in the HTLS Manager? That config file is the old way of running HTLS, I don’t really support it anymore (just importing and converting it).

Well I basically import it each time I use the script.
What is the preferred way of doing it? is that importing it and then save it or?

btw. What do you think about the spacing I choose?

There are some things I would change. I would set reference glyphs, especially for lowercase I would set a glyph at x-height (x, maybe) as the reference glyph. Then, I don’t understand why you have an extra setting for ligatures.

The values look okay to me, although I would expect the (proportional lining) numbers to have the same spacing as the capitals, so the same factor. Depending on the design, I would set H as the reference glyph.

In general, I would set more specific reference glyphs, also for the punctuation.

Why do you import this every time you use HTLS Manager? You can save your settings as a profile and import that.

Thanks @SCarewe for the feedback!
I tried correcting, but it still crashes every time :frowning:

Now I’ve tried to reinstall all plugins, modules and even python. I’ve also tried a lot of different files, but nothing seem to work it keeps crashing.
I’v also tried a memory and CPU test while it runs the scripts, but that doesn’t seem to be the problem. I’m lost and it’s really frustrating since I really love that script.

What version of Python do you have?
And can you send your .glyphs and config files to someone familiar with the Letterspaces and explain how exactly you run it? Maybe they can reproduce it?

I have the latest versions see images. I’ve just reinstalled python and all the modules. I’ve also tried deleting the preference files but nothing seems to work. A few months back I even reinstalled the programme.
It’s not only one file but all my glyphs projects, so I guess it’s with the programme or python. And in that regards, I don’t have any I could send it to.

I thought about that I have FontBakery installed through terminal. Could there be some interference with that programme and python installed there?

Screenshot 2023-11-16 at 15.57.24

@GeorgSeifert when I check Python in terminal it looks like this:

Could that interfere with Glyphs python version?