HT LetterSpacer

Did you delete (or not install) defaultConfigFile.py? All the .py files must be in the same folder.

Thanks, I’ve downloaded the script map again and made sure everything is in the same map, the config file is there, but now it’s saying this:

Start
Config file exists
Traceback (most recent call last):
File “HT_LetterSpacer.py”, line 233, in
HTLetterspacerScript()
File “HT_LetterSpacer.py”, line 71, in init
self.config = readConfig()
File “HT_LetterSpacer.py”, line 51, in readConfig
newline[3] = float(newline[3])
IndexError: list index out of range
End

Did you set your config values as described in the readme?

Stupid me… Forgot to set up the config file in the map where my glyphs font file is located, it’s working now! Thanks!

Maybe open an issue on the letterspacer repository get a better error message.

Can someone explain why do I get this error?
I have the latest modules installed with Glyphs (1099).
All of the original files (downloaded from the site) are placed directly in Glyphs Scripts folder (/Open Scripts Folder).
I am getting this error in the macro when I try it on the ExampleFont.

Traceback (most recent call last):
File “HT_LetterSpacer_UI.py”, line 19, in
import HT_LetterSpacer_lib
File “/Users/realist/Library/Application Support/Glyphs/Scripts/HTLetterspacer/HT_LetterSpacer_lib.py”, line 19, in
from objectsGS import *
File “/Users/realist/Library/Application Support/Glyphs/Scripts/objectsGS.py”, line 42, in
if type(GSElement.parent) != type(GSGlyph.parent):
NameError: name ‘GSElement’ is not defined

Try reinstalling the Modules in Preferences > Addons.

In the issue description, I meant that I have installed the latest modules.

Can you tell me what the error means? And why it comes up?

Please re-download the file objectsGS.py manually from https://github.com/schriftgestalt/Glyphs-Scripts
Somehow the updater can’t overwrite old version. I see if I can fix that.

Georg,

Glyphs is totally screwed when I tried to replace the objectsGS.py manually. Once I removed the file, Glyphs don’t want to start. As you can see there is no Update button from the menu.

The Beta warning has nothing to do with the scripting file. Please download the app again from the website.

Downloading from website did the trick. Now everything works.

When you run betas, make sure you keep them up to date: activate both checkboxes in Preferences > Updates.