HT LetterSpacer

Excuse me, please.
I know my question it’s a little basic, but I can’t install the “HT LetterSpacer”.

I can understand how it works, but i was reading all the day how to install it , and I don’t know how to do it.
Please.

You need to put the script (the .py file) in the script folder. You get there for Script Menu > Show Script Folder. The open the script menu again, hold down the option button and kick Reload Menu.

1 Like

this script seems very promising, so i installed it as well, but i seem to have issues too.

first: installation. there are two py-files (one with ‘lib’ in it and one without) and i put both in the scripts folder. is this correct?

second: interface. when i call HT letterspacer from the scripts menu, i don’t get the interface panel, though something uncontrollable seems to happen to my spacing, so something is actually working. does the script require a certain version of Glyphs? i work with #895.

third: the configuration file. i use the the provided ‘ExampleFont_autospace.py’ and changed it’s name to match my font file name.
i have no idea what this file does and whether or not i need to edit it, and if i do, what to change.

thanks for any help,
alex

1 Like

Did you see the documentation page of the script? It should answer your questions.

Alex, I did the same question to Andres Torresi. He answer this. Works for me.

For making it work with an UI it is necessary to set the value on the script
window = True
I duplicate the script file and change the menu title like
MenuTitle: HT LetterSpacer UI
So then you have 2 versions, one to work with the customParameters and one to put the parameters on the fly.
It is much better if you assign two different keyboard shortcuts to each script, and you can access them easily all the time.
This explanation was lost on the documentation, we will update it in the next days and months.

hi georg and sergio, thanks for your answers.
i did read the documentation but that didn’t help. but the trick with altering the script does!
thanks, alex

I´m doing all the steps as in the documentation, but not working for me :frowning:
My robofab script it´s out of date?
On the macro panel I´m having this info with any typeface:

import HT_LetterSpacer_lib
  File "/Users/yorlmar/Library/Application Support/Glyphs/Scripts/HT/HT_LetterSpacer_lib.py", line 19, in <module>
    from objectsGS import *
  File "/Users/yorlmar/Library/Application Support/Glyphs/Scripts/objectsGS.py", line 7, in <module>
    from GlyphsApp import Proxy, UserDataProxy
ImportError: cannot import name UserDataProxy
End

What version of Glyphs do you have?

2.3 (895)

You might need to update to the latest cutting edge version. Activate it in the Preferences.

Thanks Georg! I will try tonight.

I get this error in the macro panel:

Start
Traceback (most recent call last):
File “HT_LetterSpacer_UI.py”, line 19, in
import HT_LetterSpacer_lib
File “./HT_LetterSpacer_lib.py”, line 19, in
from objectsGS import *
AttributeError: ‘module’ object has no attribute 'RAnchor’
End

Any ideas how to fix this?

Do you have the latest version of the LetterSpacer and the latest version of the roboFab wrapper (the objectsGS.py file)?

Thank you! After updating the modules everything worked fine! :slight_smile:

Still doesn’t work for me with Glyphs Version 2.4.1 (956) and the latest HT Letterspacer version.
The script has no influence on the fonts sidebaerings. Same with the letterspacers example file: ExampleFont_autospace.py
I checked the documentation on huertatipografica website but couldn’t find a solution.
Thank you!

Did you install the modules from:
Preferences/Addons/Modules/Install Modules?

1 Like

Check into /Library/Python/2.7/site-packages if don’t have duplicated an folder called fonttools,
I had this problem.

1 Like

Thank you etunni. Looks ok to me. What do you think?

thank you guys - it now worked.
the HT_LetterSpacer_UI.py file was missing and received this error:
Start
Traceback (most recent call last):
File “HT_LetterSpacer_UI.py”, line 22, in
from defaultConfigFile import *
ImportError: No module named defaultConfigFile
End

I’m having issues installing the script as well, my macro panel is telling me this:

Start
Traceback (most recent call last):
File “HT_LetterSpacer_UI.py”, line 22, in
from defaultConfigFile import *
ImportError: No module named defaultConfigFile
End

Any ideas what to do now?