I exported a font and now I can't remove it

Hey all,

I have recently exported the font which I am working on as a variable-font to test it in Adobe Illustrator. That part worked fine. I did not export it into the Adobe Fonts folder in my library but somewhere else and installed it through the fontbook. (I read that thats not good practice and now I know why … )

Now I can’t remove this now old version of the font from my system.
Curiously it only shows up in Adobe Illustrator, no other app. When I export the new version to the Adobe Folder I see the same font twice in Illustrators drop-down menu. This is very annoying because one is the outdated version and they have the same name.

Things that I have tried:

  • I removed it in apples fontbook
  • I installed a new font managing system and looked there. (The font doesn’t show up)
  • I cleared the font caches by restarting in safe mode
  • I cleared the font caches through the terminal

How can I remove this „Ghost“-font from Adobe Illustrator?

All the best,

Remove the font from font book and clean the cache. Read here how: Eliminating font cache problems | Glyphs

Thanks for the swift reply!
I already did that, but it still shows up in my Illustrator dropdown.

Did you restart the Mac? And do they show up in Indesign?

Yes, I restarted my Mac and no, the font does not show up in Indesign.

Only in Illustrator and nowhere else? Do you have a Fonts folder in /Applications/Adobe Illustrator/?

Yes, only in Illustrator.
Nope, I already deleted that folder.

Have you restarted the Mac?
Emptied out the Adobe Fonts folder?

I have tried all of that. The only place I can select the old font is in the recently used section of the dropdown menu in Illustrator.

I will uninstall and reinstall Illustrator and see if that helps. If it doesn’t I’ll just find a way to work around it somehow.

Thanks @mekkablue and @GeorgSeifert for your help regardless! :slight_smile:

Then you might search for “delete Adobe font cache”.

Will do!