Icons in iconfont exporting with "margins" (Glyphs mini)


I’m having a problem with an iconfont I am creating. I’m having trouble finding a solution in the tutorials.

I have set it up so that icons take up the entire cap height (I think). Yet it is not exporting that way – it has “margins” above and below the icon.

The icons are for an app I’m building and my programmer is using the app as a webfont (not installing it in Fontbook).

I would attach examples but since I am a new user I am not allowed apparently…

Thanks a ton in advance,

Go into Font Info (Cmd-I) and adjust the Ascender and Descender values accordingly.

Hello, thanks for the response.

I have already tried to make the Ascender and Descender = zero. But that doesnt do it either…

Not zero. That is dangerous. at least one of them needs to be bigger. Please read this:https://glyphsapp.com/tutorials/vertical-metrics Glyphs Mini lacks the settings to control this in detail, but it might help to understand the problem.

I would set the ascender equal to cap height and descender to zero. Then try to reduce the UPM and see what happens.

Thank you so much. Will try this!