Illegal character

Unfortunately I still get the export error: Illegal PostScript mameIllegal character in “something.fontName”. When I use the dot/period in my name.
I haven’t set any PostScript name manually. Wasn’t glyphs suppose to discard or remove the dot from the ID 6 automatically without any error?

For now, you need to add a postscript name parameter that don’t contain the period.

Can i set that in some way on the general font info panel or do i have to do that on all instances?

There’s a mekkablue script for that, Font Info > PS Name Maker.

The OTVAR safe option currently does not seem work. I’ll have a look.

Thanks and that made it possible for me to export. But the problem with setting the “Font Name” is that it also rename all the font files when exported. Is there a way to set just the ID 6 name in the Font/General tab?

Name ID 6 needs to be unique in for each instance.

Okay. But It should be possible to just make a PostScript FamilyName in the Font/Generel tab.

Basically my issue is just that I name my fonts “something.FamilyName” and suddenly i can’t export because there is a dot in the name. As discussed earlier. The best solution would just be if Glyphs removed the dots for the ID6 as you already do with spaces. But that is not possible for now. (Do you have any plan on when this will be added?)

So I’m just looking for a way to change the postscript family name and not setting all the “Font Name” on the instances since that is a hassle and also change the file names of the Exported.

I do most of my export by script anyway, so is there a way to remove the dot from ID6, by script?

I fixed it.