Import kerning from other glyphs file

I think I might have accidentally lost all kerning I have done. I tried to apply a script named 'Set Kerning Groups (Lat-Grk_Cyr) (it was under ‘Scripts -> Metrics and Kerning’ on the menu) and apparently I lost all kerning that I have done until now. (apparently, it set the kerning groups but erased the kerning values themselves) Luckily, I always save versions of my files when I need to do some big changes. So, please, how do I, first:

  • Import all my kerning pairs from a previously saved .glyphs file?
    and second:
  • Is there an update for that ‘Set Kerning Groups’ script?

Thank you so much for your support! Please, help me!

(also, when importing kerning from another .glyphs file, do I have to do this master by master? Is there a way to import all masters kerning values at once?)

It was like this before I applied the script:
45%20PM

And this happened after I applied the script:
20%20PM

That can be done with File > Import… > Metrics. Then pick the other file. If the classes match already, open both files and copy paste the kerning from the kerning panel.

1 Like

I have both files opened. Before doing what you suggest, is there a way of undoing the script? I tried undoing but the kerning didn’t return.

The option to import the metrics is greyed out. What should I do?

31%20PM

What do you mean by ‘if the classes match already’?

I did a cleanup and I was left with 168 kerning pairs. I will try copying and pasting from one kerning panel to the other, so I don’t lose these and get the previous ones from the older, previously saved .glyphs file.

Anyway, is there an updated ‘set kerning groups’ plugin? Is it safe to run it?

Thank you!

Tried copying and pasting from one .glyphs file to another and it seems it’s not copying all kerning pairs. I feel lost. How do I delete all kerning and just replace it with the kerning from the other file? Tried erasing all kerning, and in my kerning palette window, although it’s not showing any kerning pair, the counting shows ‘18 pairs’.

14%20PM

You seem to have set a filter in the kerning pane. Can you click on the locking glass an in the menu select “Reset”.

1 Like

I think this is what happened:

  1. You had class kerning, e.g., @x-@y:10, and glyphs with kern groups of the same name.
  2. You ran the script, which assigned new group names to the glyphs, e.g. to @LCX and @LCY.
  3. It left the kerning values untouched. So there was still @x-@y:10 in the font, but no glyphs had corresponding group names anymore. This is called ‘orphaned kerning’. In Edit view, it looks like the kerning is gone. But it was still listed in Window > Kerning.
  4. Clean up kerning removes orphaned kerning. Now the kerning info was definitely gone.
1 Like

Select all glyphs first.

1 Like

True! Did that and now I can see really every kerning pair that was left. I didn’t notice that at first, thank you so much, @GeorgSeifert!

Thank you, @mekkablue ! I think that’s indeed what happened. So unfortunately I erased all my kerning and now I will have to import kerning from another .glyphs file which I had saved before with just a bit less of kerning pairs. But I guess now I can’t undo my deleting. Honestly, I find this kerning nomenclature and more technical kerning stuff a bit confusing. I will try to do the kerning import now. Thank you so much, Rainer!

@mekkablue, when I try to import from the other .glyphs file, it shows this window:
16%20PM

Why won’t it let me import the kerning itself? What’s the difference?

If it is a glyphs file, just copy. And paste the kerning from kerning window to Kerning window. After you imported kerning groups of course. Or actually, it does not matter when you do which step.

1 Like

So, Kerning Groups = Kerning Classes? Why is it not possible to import the kerning?

What you want is not an import. You want to copy and paste the kerning. Importing kerning is only enabled if it’s a different format, like UFO.

So just open the font, got to Window > Kerning, select all, copy, switch to other font, click into the Kerning window to set the focus, and paste.

1 Like

So, I did it and apparently it worked. One thing I’ve noticed though it’s that it seemed that I had lost some kerning, anyway, but as I start to rename my Kerning Groups to what it was before I applied the script, it’s that kerning seems to ‘return’, so maybe all that I could have done before was to rename the kerning groups, after all…
Anyway, sorry about the confusion.