Inconsistent kerning in Word vs Glyphs


I have created a font in Glyphs Mini 2 and it all looks fine in there. When I export the font and type some text in Word, the kerning is off and the spacing between letters is different than in Glyphs.

Glyphs at the top, Word at the bottom:
Screen Shot 2021-09-12 at 4.04.37 PM

Notice that, in Word, the space between “f” and “g” is larger and between “g” and “h” is smaller. What can I do about this?

Hi. If I remember correctly, Word doesn’t automatically have kerning enabled for, you need to activate it individually per document. In your image above it simply looks like the kerning is disabled.

In Word, go to Format > Font, click Advanced and check the Kerning box under Character Spacing.

@SCarewe is probably right that the kerning is disabled in Word.

But that means that you have fixed the spacing with kerning pairs and that is really bad. Please read this tutorial: Spacing | Glyphs

And also read this: Eliminating Font Cache Problems | Glyphs