Installation for multiple users on the same Mac

Greetings Forum,

I work IT for a University that wants to use this software in our Design lab.

Is it possible to install this software on a machine and have any user that logs on be able to access it?

And to add to this, all of our users (students and faculty) have accounts/profiles created when they first log on to a machine with “domain” credentials. This means that their profile and paths do not exist before they log on to the machine for the first time. Is it possible to have the software work for these users in this manner?

If either of these questions can be answered “yes” I would very much appreciate any information or direction on how we can make it happen.

Thanks to any and all who take the time to read this and my eternal appreciation to any and all that may be able to help me solve this riddle.

Angus M.

You need to install (the same) license file on all machines. That can be done from the terminal by one command:

sudo /Applications/ "/Path/To/Your/License/File.glyphs2license"

And don’t leave the license file in the machine.

I am in the same situation as turing8. I have ran the above in the local admin account, and it completes; however Glyphs is not activated for any user but the local admin account. We are running OS X 10.10.4 and just like turing8, accounts are created at login (may not be there when the command is run).

What is not there when the command is run?

The user accounts may not be there when the command is run as they are Active Directory accounts and the same person may be using a different computer the next day.

The command should instal the license in /Library/Preferences. Make sure that the accounts do have read access to it. It has to do with how the defaults system works.

com.GeorgSeifert.Glyphs.plist is in /Library/Preferences. System has read & write, wheel has read only and everyone has read only. When Glyphs is launched in any other user but the one the command was run in, you get the following pop-up:

The License information is not valid. Please reregister. Glyphs will run in Demo Mode.

We just finished a tutorial that describes all needed steps:

I believe that latest2.php URL downloads a .zip file, so redirecting the output to /Applications/ may not be what you want in that tutorial. Unzipping the downloaded .zip file does produce the folder/directory. fyi.

True. Thx for pointing out. Will fix soon.

Edit: Fixed!

I have followed your instructions, but it will only license for the user the command is run in. We are using Glyphs 1.4.5 (614). Could this be the problem? When I get Glyphs 2.1.1 (768) as per your instructions, it says it can’t read our license file.

Error: The document “xyz.glyphsLicense” could not be opened. Glyphs cannot open files in the “Glyphs License” format.

Glyphs 2 needs a different license file. It has a .glyphs2license suffix. Note the digit 2.

Yes, I noticed the 2 and the version that was being downloaded. Following these instructions for Glyphs 1 works, but only for the current user. So basically what I’m asking is are there separate instructions for Glyphs 1? Does Glyphs 1 even support multiple users to be licensed at once? If not, can we upgrade our license, etc.?

Don’t know if G1 can be set up in this way. Upgrading instructions are on the Buy page, look for an item about upgrading.

I just tried and it works fine with Glyphs 1. Maybe some of the user settings prevent access to the Systems library preferences.
After you run the command, there should be a file /Library/Preferences/com.GeorgSeifert.Glyphs.plist You might try to copy it to ~/Library/Preferences/com.GeorgSeifert.Glyphs.plist for each user.

It is working now. You guys have great support. I did have to copy the plist into ~/Library/Preferences.

I got around the issue for users who have not logged in yet by copying the plist to the “Default” user:

rsync -av /Library/Preferences/com.GeorgSeifert.Glyphs.plist /System/Library/User\ Template/English.lproj/Library/Preferences
chown root:wheel /System/Library/User\ Template/English.lproj/Library/Preferences/com.GeorgSeifert.Glyphs.plist