Instances & Masters

Hi, I’ve searched the forum but I couldn’t really find what I’m looking for. In one thread you were saying that the whole master-issue is covered somewhere, could you provide a link?

Heres the problem:

I’ve an already existing typeface that I want to work on, regular, light and bold.

I want to setup the light and bold as masters to create instances.

Now when I load light and bold as masters I can’t make instances, even though I’ve typed in all the neccessary information. Also, I can’t export the font, I always get an error saying:

syntax error at “]” [/Users/mac/Library/Application Support/Glyphs/Temp/Font-Regular/feature 28]
makeotfGlyphs [FATAL] aborting because of errors

Also: what are the User Parameters exactly?

In the help section you just write very briefly about how to set it up correctly, also the screenshot doesn’t seem to be up to date, at least my master panel looks a bit different. Is there any resource where you explain this whole topic a bit more in detail?

BUT: great great great programm, I’m really starting to love it, especially the quick work with the shortcuts is awsome!




How to set up a the masters to be able to interpolate is explained in the in app help. Goto Help Menu > Glyphs Help > Setting up a Multiple Master Font.


Hi Georg,

I’ve looked that up and I’ve also tried it but unfortunately it doesn’t work I’m still getting the error message. Have you got any suggestions? Thanks a lot!

So, you have a font with several masters? The most important Master setting is the value next to the Weight pulldown. e.g. measure the vertical stem width of the small “n” and put in this value there (you may end up with something like 40 for the light and 130 for the bold). Both masters need to have different value in this field.

Then go to the instance settings and add one with the plus button at the bottom left. Put in a name and a weight value (something between the two values from the master settings). Now you might test it and choose Font Menu > Generate Instances. It should open a new font.

The error message from the export seems to be caused by an error in you features. Can you open the file “/Users/mac/Library/Application Support/Glyphs/Temp/Font-Regular/feature” in a text editor and have a look at line 28?

If you can’t resolve the problem, can you send me the .glyphs file offlist?


Hi Georg,

sorry for my late reply, I was off for a couple of weeks. But thanks for getting back on this, here is what is in line 28, can you work with this? I reckon this is something that is left from fontlab, as I startet creating the font there, is that possible?

} name;
@xxxx = [];
@Uppercase = [A AE Aacute Acircumflex Adieresis Agrave Aring Atilde B C Ccedilla D E Eacute Ecircumflex Edieresis Egrave Eth F G H I Iacute Icircumflex Idieresis Igrave J K L M N Ntilde O OE Oacute Ocircumflex Odieresis Ograve Oslash Otilde P Q R S T Thorn U Uacute Ucircumflex Udieresis Ugrave V W X Y Yacute Ydieresis Z];
feature aalt {
feature frac;
} aalt ;

Thanks a lot for your help and patience!

No, you created a empty class (named xxxx). You should delete it (in Font Info > Features).

Hi Georg.

I should add a question to Instance values. I set up two masters so far, Light Cond and Bold Cond.
The basic idea is of course to interpolate several cuts in-between.

The question is: if instance value 0 corresponds to my light extreme (not exactly actually), which is the value for the bold one? In FontLab (btw, thank you for freeing us:) was 1000, but in Glyphs, creates a lighter instance…

I hope I made the question clear enough.

Thank you very very much


You mean the weight field in the masters settings?
in the masers settings set a unique value for the weight for all masters. I usually use the stem width of the “n” as described above. So you end up with values like 30 for the light and 183 for the Bold.
But you also can use 0 for the Light and 1000 for the Bold.

In the instance settings, set corresponding values in the interpolation > weight field.

Does that answer your question?

Thanks for the quick reply Georg.

Actually I was referring to the Interpolation values in the Instances pane, but your reply helped me understanding that the those values are linked to the ones of the Master. As said, I’m used to Fontlab, and I thought those values acted the same way. Now I got it, and I find it pretty straightforward.

I’m really getting acquainted to Glyphs, and I like it a lot.



Hello Georg.

me again on a Multiple Master issue.

for every glyph I design on both masters, I have to carefully check that the number of nodes is exactly the same, that they share path directions and, better, if they have corresponding first node. After doing this, usually everything works fine.

now I’m working on a ‘R’ which has an awkward behavior. If I press cmd+opt+ctrl to check nodes pairing, it looks like some links to an handle instead of a node and everything is messed up.

here’s a screenshot which probably better describes what I’m trying to say

Thanks a lot


This happens sometimes, if the start point not set correctly or the paths is not compatible. This not something to worry about. Just try to make them compatible.

This first thing to do is to select “Correct Path Directions” from the Layer menu on all masters. This will sort the paths and set start point in a consistent manner.

In your case, you seem to have a curve segment in on master and a line in the other.

Thank you Georg…

I did what you suggested, but it still didn’t work.

After some random click here and there, suddenly it worked! :slight_smile: