[internal] label not found

Trying to export to .ttf Glyphs display following error without exporting. Does anybody know what might cause the problem?
25

I ran into this error as well on a font I had imported and was tweaking. It turned out it was something in the Features tables, seemingly a syntax error in a language declaration. Ultimately, I just eliminated the feature, but I’m sure a more careful look would have lead me to correct the syntax problem on the import.

Use the little “compile” button at the bottom of the Features screen to test this theory. I hit the same error in the ‘frac’ fraction definitions.

If you hit this, try removing everything in the features code—just to see if it compiles. Then add it progressively back to isolate the error.

This might help: https://glyphsapp.com/tutorials/troubleshooting-a-font-that-does-not-export

1 Like

This error message stems directly from makeotf and is unfortunately badly worded. It usually occurs if you:

  1. define a lookup after a script (e.g. script latn;), but before a language (e.g. language NLD;) declaration,
  2. and later in your code, call that lookup again without a script or language declaration.

Moving the lookup in question above the first script statement usually fixes the problem.

The error can be easily solved by generating features automatically.

1 Like