Interpolation/Synch bug

This happened for the 3rd time since upgrading to V. 806
Looks like an interpolation bug that occurs when replacing paths in any glyph by simply (Delete) and (Paste in the glyph window) from other glyph in the same master (NO Paste Special used).

Wondering what is the Green outlined silhouette of the removed paths

The bottom preview and tools turns gray and dimmed instead of black and the Preview bar + buttons turned 180° upside-down (top left corner)

While fix Compatibility filter is showing un-equal number of paths in each Master.

These Interpolation synch bugs, are also happening to me a lot.

A frequent thing is, after fixing compatibility, the glyph is still marked as incompatible. I have to quit Glyphs and open it again for it to be synched.
I have the impression that is something to do with the path order, because I also have difficulties in using an interpolation macro I normally used with no problems.

Sometimes, when these bugs are taking effect, some refresh issues start to happen with button disappearing on the panels to the right.

The font I’m working on has 4 masters.

What plugins and scripts do you use?
This things might happen if you use a method that messes up the state of the glyph. What did you do before (a few minutes, not just the last few steps) that might cause it.

In all cases … the bug occurred … when having worked on reshaping a glyph in one master (I’m using two Masters only) such as changing the weight… but some times you need to borrow a segment from another glyph.
My suspicion go to > when deleting all paths in a glyph you’re working on … while keeping anchors, then go to copy a path from other glyph (NOT Component) the bug takes place just by pasting the copied path into the relevant glyph !

No plug-ins were involved !

I think the only plug in I have is “show handles everywhere”.

I made this multiple master file using glyphs and have been working on it, synching outlines, reshaping, synching again, with no problems. This is only happening after the last update.
When this stuff happen I haven’t done anything special. The pattern I think I detected is when I past a new path in one of the masters that I’m tweaking, that glyph won’t be compatible again, even after I make it compatible again. I have to restart glyphs for that character to show a synched glyph.

Sometime that green outline (that Avantino showed) appears, and overlapping number indexes, but I don’t know what causes that. I have to close glyphs and open it again.

This is what I mean about the outline indexes. This letter has only two outlines, but index number goes from 1 to 4 in this case it happened because I did Cmd-X & Cmd-V to the contour on the right (the entire path not just part of it). When I paste it increments the path index +1, as if I was accumulation lots of paths over and over. While this is happening the panels on the right start having problem of refresh, if I rescale the window, buttons disappear.

Hi @Rui_Abreu,

I had that problem a few months ago. I worked around using this script in order to understand what is happening at the path level:

for thisLayer in Glyphs.font.selectedLayers:
   thisGlyph = thisLayer.parent
   if thisGlyph.unicode:
      print "\n",, '"%c"' % unichr(int(thisGlyph.unicode, 16))
      print "\n",
   for layer in thisGlyph.layers:
      print "\t",
      if len(layer.paths) == 1:
         print "\t", len(layer.paths), "path:"
         print "\t", len(layer.paths), "paths:"
      for path in layer.paths:
         print "\t"*2,path

You are going to have a list of paths for each layer in each glyphs. Comparing the path index and the amount of nodes, if there is an extra path, you can deleted it by its index using:

# delete path



1 Like

I understand the problem, and fixed it.

1 Like

it looks like a handy script. Thanks for sharing :slight_smile:

I also am experiencing the issue Avantino described with Master Compatibility. My version is 806.
Is it fixed in v 807?