iOS emoticon not showing center of the character, always Top

When export for iOS font like iColor 96, iColor 128, iColor 256… but in the text editor, emoticon shows upper site of the Character. shown below,

i wanted to show that emoticon like middle of the character as shown below

i’m stack on that. can’t find any solution to shows that emoticon in the middle. try x-height, baseline, cap-height from transformations. but get no solution

Can you send me the file? and one of the images?

There is one thing you can do is to put a tiny piece of outline in the place where you like the lower left corner of the image to be.

gg emoji (151.2 KB)

@GeorgSeifert >> attached file is the sample project where i stack. Please check

As I said, you need to put a tiny piece of outline in the main glyph (the Regular layer not the color layers) where you like to have the lower left corner of your image. Draw a small square (5 units) and delete two of its points to create a invisible piece of outline.

Thanx brother. it works :slight_smile: but there is little bit problem. you are saying “delete two of its points to create a invisible piece of outline.” but when i delete any of 2 points, it doesn’t work. if let it four point, then there is a doted point shows with emoji :frowning:

It does work. You need to simply delete the nodes, don’t brake the path. It has to be a triangle and a square, not two blue line. And export without remove overlap.

when i delete the point or node… it looks like this.

how can i simply delete the nodes without braking the path?

It should look like in the first image. I usually keep the leftmost nodes but it should work as a diagonal, too.

i tried to both. 1st screenshot also not working :frowning:

Are you removing overlaps at export? Don’t. At least not for this letter.

Wow. Now it works. thnx @GeorgSeifert & @mekkablue brother, both of you solve my headache. all the time i export the font with removing overlaps. that is why it doesn’t behave normally. I appreciate your supports :slight_smile:

got another issues. When i use this emoji, next to the emoji, the character changes it’s different font.
Let me clear this issues:
In a TextEditor, simply select a font and start writing something. after using my custom emoji font start writing again. but this time font is not same as i selected. So before emoji and after emoji font are not same. it looks odd :frowning:
what can i do with this problem ?

That is not a problem of the font per se. This usually happens if you type a letter that is not in the font. You can analyse your character stream with UnicodeChecker, and add a glyph with the respective Unicode to the font. Again, make sure you do not have cache problems.

Every time you type something with a font that doesn’t have that character, the system switches back to the default font. It doesn’t remember what font you had selected before.
The easiest solution is to first type all normal letters and then add the emoji.

thnx brother for the info. is there any other way to solve this issue ?

Not that I can think of, only workaround. So, when you type, always type one extra space before you insert the emoji, then you can continue typing in the original font.

oke brother i should keep it mind. Thnx for your support :slight_smile: