Issue with font in Adobe Indesign glyphs panel

Hi,

while working on a new font and testing it from time to time in Adobe applications I witnessed a strange behaviour in the Indesign glyphs panel (v 17.4 and v 18.0). As you can see on the screenshot, my font is been displayed pushed up in the glyphs box and not straight centered as it usually should. Apart from this the font itself works and behaves absolutely how it should in Indesign. Strangely in the newest Illustrator version (v 27.0) it isn’t an issue with the glyphs panel there…

Also to mention that older exports of my font (I guess still Glyphs 2 exports) don’t have this issue in the newest Indesign version. So far I also never changed specific settings as I compared these files with my newest export in Glyphs v 3.1.

Has someone experienced similar issues? I`m not sure if it is a problem with certain settings of my glyphs file or an issue by Adobe Indesign itself. So far I couldn’t find anything here in the forum or elsewhere and would very happy if someone knows what the heck is going on there…

Thanks!

Jan

This is determined by the font bbox, i.e., the highest and lowest points in all of your font. There are test scripts in the mekkablue scripts that help you find those glyphs.

Thanks for your fast reply! I checked it yesterday evening with mekka blue script and so far it doesn’t look like there’s a point way off too high or low somewhere by accident. In the screenshot you can see the results and there’s nothing wrong to me (–> not all masters are finished yet, that’s why glyphs vary here).

I also exported older versions of my font in the newest glyphs v 3.1 and there this problem does not occure in Indesign. Although while comparing the settings of the font files, there’s nothing seriously different (at least what i see…). Also pretty confused why this isn’t happening in the Illustrator glpyhs panel on the other hand…

Any guesses what I should check next?

Can you check the lower case ‘d’ in all masters. The bounding box of the ‘d’ is used to determine the first baseline.

First thank you for your help! I checked all lower case »d« in each master and couldn`t find anything suspicious. I used »remove stray points« on each letter to make sure, that there’s nothing I accidentally missed to see. But no success in Indesign after exporting again…

Could it be something in my custom parameters? But also checked them several times and they`re the same as in my older exports.

My suspicion was that the ‘d’ are not tall enough.

Double check your vertical metrics. Perhaps try an export with a different name.

Are you using the Adobe Fonts folder?

Thank you both again for the support so far! The »d« is tall enough for sure. Double checked vertical metrics, also made up a different name for my export with both no positive result. More of the troubleshooting so far:

• at my colleagues mac with Glyphs version 3.04 the same file (direct share via dropbox) exports completly fine (behaves the right way)
• downgrading my Glyphs to version 3.04 brings up the same mistake after export like it was with v. 3.1
• interestingly while using your recommended Adobe font folder method (before I was exporting regularly and activating the font in Font Explorer), my export aren‘t recognized at all in Indesign, Photoshop and After Effects but (!) in Illustrator. There it works completly fine, also the glyphs panel shows up everything centered like it should. Using my colleagues exports here (putting them in Adobe font folder), they also work in all applications just fine…
• so far I tried everything, from installing Glyphs completly new (3.04 and 3.1), also Indesign (17.4 and 18) and even updated my OS from Monterey to Ventura today. Performed several restarts and also I’m completely aware of cache issues, so I took care about that too. Nothing of that helped…

I’m trying it tomorrow on my Macbook from 2014 to see how the exact same file behaves after exporting it there with Glyphs 3.1. Today I was using a Mac Studio (32 GB RAM) with M1 Max chip. Don’t know if it’s some issue caused by that, but it definitely is not exporting the right way on this machine…

So I assume you didn’t use the Adobe Fonts Folder. Sounds like a font conflict then. Or a font cache problem. Read this please: Eliminating font cache problems | Glyphs

The latest troubleshooting i did was indeed with the Adobe font folder and not via Fontexplorer (already deleted it completely → Adobe font folder works way faster for testing, thx for the advice :ok_hand:). So I also cleaned up the Apple Type Server and did another restart –> then the new exported file to the adobe font folder reacts the same with it’s bounding box issue (also the file behaves the same on my colleagues 2020 Macbook Pro and on my 2014 Macbook Pro)…

As I already wrote the last time: Exporting the same Glyphs File on my colleagues Macbook (via shared dropbox folder) does not have this issue. This file works also fine on my Mac Studio.

Exporting it on my Macbook 2014 (Big Sur) it also works flawlessly. So the only conclusion I can make (which is also absolutly strange to me) is, that it’s just not exporting the right way on my Mac Studio –> These files do have all bounding box issues on all the above computers tested…

My workflow is now that I can at least export it on my old Macbook :smiley:

Can you check the version of Glyphs on those other machines?

And check the difference between the working and not working font. If you can figure that out, could you send me the two .otf files?

Hey,

sorry, I was quite busy the last days. Here‘s the list of computers and their glyphs versions:

• Mac Studio 2022 (Monterey + Ventura): Glyphs v 3.04 + Glyphs 3.1 (exported file didn’t work properly on both operating systems / glyphs versions)
• Macbook Pro 2014 (Big Sur): Glyphs 3.1
• Macbook Pro 2020 (Monterey): Glyphs 3.04

The difference between the files is, that the export on the Mac Studio is not shown correctly in the glyphs panel in Indesign 17.4 and 18. Some troubles inbetween seemed to be cache related and are not experienced after cleaning up the Apple Type Server and switching to the Adobe font folder method. In the “missbehaving” file, each glyph is pushed to the top of the box as shown in the screenshot of my first post. The exports of both Macbooks work completely fine. It’s only this small thing and really strange, why this occurs…

How can I send you the files directly? Is there a privat message option somewhere?

You can send the files to support (at) glyphsapp dot com.

1 Like

Thank you! I just sent the files :v: