Issue with single contextual alternate


I have a problem with contextual alternates (calt). It works like it should, in general, but not for replacing the uppercase B, and I have no clue why. I already tried renaming the glyphs (just in case) but still: when I turn on the calt feature, the letters get replaced as intended, but not the uppercase B.

sub T R' by R.calt; (working)
sub L B' by B.calt; (not working)
sub L' B by B.calt; (working, the L gets replaced)

Any tips? Have I missed something too obvious?

Best regards, Johannes

(Glpyhs 3, latest trial version)

Is this all the code?

Hi Georg, sorry to disturb your weekend. Didn’t expect a reply so fast. This is the complete code so far:

When I try to reproduce the issue from a blank file and insert the exact same code there, it works. So I exported the font and reopened the oft-file in Glyphs. The contextual alternates work fine now, but the feature code is very different.

I still can’t see why the other alternates work in the Glyphs file, except from that single letter.

Okay, just to narrow it down: The code is working fine, and so does the calt-option with the exported font. So there might be something not working properly within Glyphs I guess.

Where does the calt feature not work properly? Only in Edit View within Glyphs?

Can you try the latest cutting edge versions (activate it in Preferences > Updates)? I just remember that I might have fixed it recently.

I just did, and the issue is fixed. Thanks Georg, that’s awesome!