Issues with font installation

Hello there!

I have an issue with the font I’m designing. I’m fairly new to Glyph and never had the following problem with robofont since you can’t have multiple master in one ufo file.

I am working on a font with 2 masters (extra light and bold), I have one instance for a regular. As far as I know, everything is well regarding this part. However, after I export my fonts I have a weird issue, they look ok but once it’s installed, only the extra light appear in indesign… It’s like my regular and bold doesn’t exist. I tried fonts book, and directly adding my otf to my computer font library, but nothing change. When i use the font book I have some kind of alert as if my 3 fonts were de same, but they’re not. I’ve check my font naming in glyphs, it’s all different in “master” and “exportation”, weight number are different too. I have the same issue when I export generated instance one by one. I tried rebooting my computer, I cleaned my caches, Glyphs is updated… I’m lost.

Am I missing a step in the font setting/naming? Do you know what should I do?


When testing fonts read this: and


Thanks for your reply!
I did change my process and cleared caches with the script from your link, I cleared “Temp” folder in Glyphs, removed trace of the font on other folder and used adobe fonts folder instead of the library one, and shift reboot. However, I have now only the bold, and a buggy one without all my OT features, whereas before my extra-light was alone but ok.

What I don’t understand is that the otf generated by Glyphs are working when I open them in Robofont and export them once again in the adobe font library (minus my opentype fonction are removed, but at least I can see the 3 fonts in indesign).
I just tried the same process with Glyphs as I was writing this reply and I may be onto something: when I do that my generated otf lose its “bold” “extralight” and “regular” feature. I checked their naming, it is still there in the info board. I believe something goes wrong in the generating process, but Glyphs doesn’t indicate failure or bugs as it creates the otf.

Does it have to be a cache issue? I am at a point where I think I just need to copy past all the glyph in a new file to start fresh. :skull_and_crossbones:


Can you send me the .glyphs file?


The FontName parameter is written the same to each font. Remove the “Font Name” in Font Info > Font.

That’s It! Thank you so much, I can’t believe it was something stupid like that. I must not have understood what it meant when I add this parameter to my infos.