Issues with Variable font export

I’ve been having issues with my variable font exports. They change the glyph sizes and width and swap masters. Is this a known issue? HELP!

This is the exported .ttf

This is pre-export

I’m on Glyphs 3.0.4

Can you show your master setup? The coordinates of each master?

The instance names correspond to master coordinates

Just add an extra 0

Things I’ve tried thus far:

  • Deleting the most recent character /l, as after I made it issues started to appear
    - I didn’t have any issues with VF prior to this and did not adjust any technical
    parameters. only added new glyphs and shapes
    - this did not work
  • Copy and pasted glyphs and masters into new glyphs file
    - no difference in outcome
  • Changed file type to Glyphs 2 and opened and exported from there
    - only had 1 master exported for some reason
  • Had somebody else test the same processes on their machine
    - same issues

Resolved issue by making new font file and making new masters, copying shapes from old file to new file.

The original file needs a Variable Font Origin parameter in Font Info > Font. The first master in your file is a “intermediate” master that can’t be the origin. So you need to define any of the others as origin.

Or reorder them in the master list that the 50/50 master is not the first.

1 Like

I see, thank you for your assistance Georg!


I’m having some issues with exporting a 5 master variable font on a weight width axes font.
I have :

But when I export it with 1:700 for some reason it makes the font do some reverse contrast thing in the 400:700 range. The masters are still normal but the interpolations and instances get thrown off. I have it set for 2:700 at the moment which seems to fix the issue except for the small skip at the beginning. I also use Variable Font Preview 3 by Mark, which interpolates the paths normally in the app.

I also have the Variable Font Origin parameter set now at 1:1.

Would I need to have a sixth master to fix the issue or is it something else I am not aware of?

I’ve tried six masters. The sixth being 1000:850 (thats the stable version I have). And that has also not worked.

Do I need to set 1 values to 0?

Thank you for your time!