Kerning does not work in variable font

I think this problem is newly added to the Glyphs program! Before the update, kerning was executed correctly in variable and static fonts, but now it is executed only in static fonts.
Does anyone have any comments?

Screen Shot 1402-04-20 at 02.08.55

What version of Glyphs do you have? This should be fixed in the latest cutting edge version.

this is cutting edge version
Apparently the problem is not solved
What is the solution now?

In previous version I did not have a problem!

I’ve recently been experiencing a problem with the kerning in variable ttf exports, and after checking a few older versions it only seems to be a problem in 3203+ (3202 and older work fine). Perhaps the same issue? Everything appears as expected in the application and Preview Panel, but when I export the font, the spacing looks different.

Exactly. This problem occurred in the new version

What problem exactly? No kerning at all? How do you test the exported font?

Here are some comparisons from and Font Gauntlet of the exported ttfs. I’m happy to email you the files directly if it helps with debugging.

Glyphs 3202

Glyphs 3205

For my font: I have 3 masters and kerning is executed only for firs master

It seems that the old problem has been implemented again
Can I go back to the previous version?

I used Glyphs Versions to identify the specific build where the problem started to appear.

Thanks a lot

Should I wait for an update?
@GeorgSeifert @mekkablue

Thanks for reporting this. I fixed it. An update is coming soon.


Thanks a lot @GeorgSeifert

I installed the new update, the problem is still in the new version and has not been fixed

Can you send me your .glyphs and the exported .ttf file?

Can I email it?

Yes, to support at this domain (without forum.)