Kerning Groups

Hi, apologies if this has been covered before.

But basically, I am making my first typeface, which is a script with plenty of contextual alternates, to which I have now added accented characters to cover as many languages as possible.

It wasn’t until I was a way into this that I discovered kerning groups, which I have started using. However, alot of my kerning values were set before I put these groups in, which means by default the group is ‘unlocked’ [the little padlock symbol] which means that I have to go and individually put it next to each letter and close the padlock. Is there a way to automatically close this for all glyphs of the same group? (For example, o, the contextual alternate and then all of the o diacritics)



You can use the “compress” function from the gear button in the kerning panel.

Thank you so much Georg! This has saved me a lot of time. I’ve done a lot of trial and error so far, and have found out a few things later down the road that would have saved me a lot of time!

But still, all experience and next time I can use these shortcuts!

As a complete novice, I can say that Glyphsapp is very easy to pick up and work with!

I am having this same exact issue too… except the answer didn’t work for me? After selecting “compress” (from the gear menu in the Kerning window- I assume that’s the option you meant) I still have many unlocked pairs.

Additionally when I manually lock them the kerning changes in very unexpected ways. For example I just locked the f - period (f.) kerning pair which was set to -130. After clicking the lock the number changed to 30.

Initially when experiencing this behavior I assumed it was reading in the information from a different pair (this is understandable but frustrating since it would seem intuitive that when “locking in the kern value” I would lock in the number I am actually seeing.) but the f would seem to indicate this is not the case as the only other letter in my “f” kerning group is the lowercase eszett for which I have not actually made any modifications yet.

  1. Has the method for locking all unlocked groups changed since February? (When this question was initially answered.)
  2. When locking an unlocked kerning value individually where is the new value pulling from and how do I control it?

I have screen shots of what I mean in case any of this information is confusing or I am not explaining well enough but unfortunately my account is new enough that I cannot include them in this topic just yet.

This sound like you are mistaking left and right groups. In f-period, it is the right group of f that is kerned with the left group of period. If you say that germandbls and f are in the same group, I bet they share the same left group.

1: no.
2: locking means applying the existing group kerning value. You must have already had a group kerning in place. Check in Window > Kerning.

Hi @Mekkablue thanks for the response!

  1. The “compress” function suggested by Georg did not initially lock my values because… you have to select all the values you want to “compress”! /headdesk When I figured that out I felt so dumb.

  2. You are correct that I was mistaking left and right groups - the f-period group was for the right group and doesn’t include anything except the “f”. Thanks for catching that! At this point I have already made all the corrections to the values so I cannot test your recommendation to make sure I am implementing it correctly but will keep an eye out for similar behavior in the future and check in the Kerning window.

I really appreciate you taking the time to respond to someone obviously so new at this! The tutorials and videos on the site have been incredibly helpful and are the very reason that someone like me who is totally new & is self teaching has made it all the way to kerning without needing to post a single question on the forum until now. They are extrodinarily thorough and clear - thanks so much for doing such a great job with them!

1 Like

You don’t have to select anything to compress kerning pairs, though you have to run it twice sometimes. In a case where both sides of a pair need to be locked, Glyphs only does it to the left side of the pair, so you need to run it again in order to lock the right. I think this should be updated.

Hi @Tosche thanks for the correction! I tried this and it worked! When I first tried the suggestion in this thread I must have only run the compress option a single time. Really appreciate it!