Kerning is not exported

The font is Variable, if I export only a .otf or an .ttf of one master, the kernings are ok, but when I export the GX.ttf all the kernings disappear.

Make sure you run the latest version of Glyphs. Consider enabling cutting edge versions and automatic checks in Preferences > Updates.

Also, where do they disappear? In which app are you testing?

I have the last version.
I’m testing the variable font in the last version of Illustrator.

Just now I see that the kerning not disappear really, it’s just it does’nt interpolate in the variable font?

It should be interpolated. What version of Glyphs do you have?


The kerning can be interpolated in a variable font? I mean exporting in the beta GX.

In Preferences > Updates, activate both checkboxes. Then press the Update button. The latest version is 2.5.1 (1140).

Ok, thanks, I’ve updated to the last version (finally) but the error of the kerning is still the same. It keeps only the kerning of the first master.

In which application are you testing?

The last version of Adobe Illustrator

I just tried it and it worked for me. Can you send me the .glyphs, the .otf and the testing file?

Hi I have the same issue with Glyphs 2.5.2 (1165). Kerning does not appear to be exported in the GX ttf. I’m testing in the latest versions of chrome and chrome canary with cache disabled but still no luck.

Are you sure it is the kerning. If there are components involved, the spacing of those is not correct on macOS.

Checking in with my experience here…
Kerning is working great in my variable font, in illustrator, except for the values in ONE master.

^Glyphs app, looking great

^Illustrator, wonky

Feeling pretty stuck about it. The values are there, it works great in all other instances.

Can you send me the .glyphs file?

Thanks for the file. I fixed it.

1 Like

Fixed it in Version 2.5.2 (1168)?
Or has it yet to be rolled out?

I think it will roll into 1169.

1 Like

The update is up.

1 Like

Incredible! Great work, as usual :clap:

1 Like