Kerning Issue when Exporting Font

Hi there,

I am using the main Glyphs program (rather than mini) and am having issues with kerning when I export my font. In the app I have set all my kerning perfectly, but when I come to export the font the kerning is totally different. I have tried emptying my font cache, and saving the font in both OTF and TTF, and testing in a range of programs but all with the same result.

Thanks in advance
Stuart

Can you send me the .glyphs file please to support (at) (this website without www). I will have a look. And give me an example of a kerning that messes up.

How are you testing the font? Are you using the Adobe Fonts folder?
http://www.glyphsapp.com/tutorials/testing-your-fonts-in-adobe-apps

And if you are testing in InDesign: are you testing metric kerning (not optical)?

Thanks for your message back. I will get the font sent off to you now.
I have been testing it in Photoshop and Illustrator, just generally typing it out.

I will take a look at the link you posted as well.

Thanks
Stuart

Okay that has all been emailed over. I tested the direct install via the link you sent me and sadly I get the same result.

Thanks
Stu

Did you install via Fontbook? This may also be a font cache problem. Read this please:
http://www.glyphsapp.com/tutorials/eliminating-font-cache-problems

Originally I installed via Font Book, but I renamed the font and tried your method of the direct install via the Adobe Fonts library but that didn’t work either. I have already cleared the cache and it didn’t help sadly.

Thanks

I tested your file, and the kerning exports as expected.

Make sure:

  • the app you test in has kerning activated (the screenshot you sent suggests that kerning was off)
  • in Adobe apps, make sure metric kerning is on, and exclusively use the Adobe Fonts folder for testing.

Thank you but I don’t believe that to necessarily be the issue. When I upload my font to the various marketplaces, they all showcase the font in preview mode the same as my Adobe products do. If it were just a kerning issue in Photoshop, the file should be correct.

Are you able to reply to my email and send me back the OTF/TTF file?

Many thanks

I have gone back into InDesign, ensured the kerning was on and set it to Metric, unfortunately that hasn’t resolved the issue for my export. Perhaps I am not exporting the font correctly?

Are you able to send me the OTF you have, so I can test this?

Thanks

Any update on this?

I have the same problem. I set the kerning between brackets () and the zero to -45, but the right bracket sticks to -75. I use FontExplorer and do testing in InDesign (with metric kerning). I have already tried multiple exports as OTF and TTF, updating the metrics of every glyph, renaming the font file, emptying my cache (including restarting my computer) and using the Adobe Fonts folder, in between which I have always quit and restarted all the software used.

Please help me!

Update 1: After updating Glyphs to the latest version (2.5 1131) at least both the brackets stick to the same value: -75. But still: it’s the wrong value. Is there something I’m missing here?

Update 2: It seems as if the values were getting calculated against the values of the capital O, which are set to -30. I am using a kerning group based on the O, which I also applied to the zero. But in this case (with the brackets) I had unlocked the zero from the O’s values, and thus Glyphs let me apply individual values to the zero, which were working fine. Only after exporting they were messed up. I have now worked around the problem by removing the zero from the O-kerning-group, but this does not quite feel like an actual solution to the problem. Do you get any thoughts on this?

Could you send me the .glyphs file? And the text you are testing with?

Don’t. Why not use the Adobe Fonts folder?
http://www.glyphsapp.com/tutorials/testing-your-fonts-in-adobe-apps

The Kerning value displayed in InDesign is normalized for 1000 UPM.

Because it let‘s me easily manage the thousands of font files I have in my library. But, as I mentioned: I already tried the font folder method as well. (Of course only after completely deleting the font from FontExplorer and quitting the application.) Also, my font is normalized to 1000 UPM too. The problem still ocurred.

As I worked around the problem I‘m afraid I have already altered the Glyphs-file and overwritten the exported file. Thank you anyways!

1 Like

I have the same problem here. Kerning in Glyphs works fine. After exporting and testing in InDesign and other apps, some pairs are correct, some pairs are not present. I have cleared the font cache, exported the fonts with completely different names, all with the same result.

And yes, i have enabled metric kerning in InDesign.

Any thoughts?

Thanks, Jan

Can you give an example?
Have you check that the pairs are written to the feature file (you find it in ~/Library/Application Support/Glyphs/Temp/FontName)

Thanks, Georg. I had a look into the feature file, the missing pairs are not written indeed.

I have located the problem a bit. It seems that only pairs with @period are affected. Pairs are not written when

  1. the other glyph belongs to a kerning group (Kerning exceptions are written properly) and
  2. the other glyph is a letter (Punctuation marks are kerned properly).

Many thanks,
Jan

Can you send me the .glyphs file and a specific pair that is missing?

Just send a link to the file via DM. Thanks in Advance

The kerning is missing because it thinks the “period” class is “Arabic” as it contains the “threedots-ar”. Mixing those scripts is not supported.