Kerning only working partially on


I have uploaded some fonts on, and I have this problem where kerning is only working on some letter pairs, but not all of them. See picture below. Kerning in AV should be as tight as in VA.


Kerning does work fully for example in browsers and in Inkscape, but just not on FontSpace.

I have some other fonts made with FontForge, and stranglely enough, kerning on those works properly on FontSpace.

  • Have you tried with the most recent beta version of G3?
  • Is it different in different browsers?
  • Does it work in FontGoggles? If it doe, it is either an issue with the glyph set and the character stream (analyze in UnicodeChecker, look for invisible characters that are unavailable in the font) or simply with the browser.

I am using the newest beta, Glyphs 3.1.2 (3151). Kerning works in Safari and Firefox. It also works in FontGoggles.

I don’t really understand what should I be analyzing in UnicodeChecker?

Did the font that work has a kern table?

I inspected the font with FontTableViewer, and there is no table named “kern”, so I guess the answer is no. There’s a GPOS table.

In UC, open a tools window with Cmd-2, one of its options is to split up a string of characters. So paste the te t you had and look for invisible characters or characters that do not have a correlating glyph in the font.

Latest beta is 3.2, build 3208. Go to Glyphs > Preferences > Updates, activate both checkboxes and press the Update button.

I updated to the latest cutting edge version, but the problem still exists.

I wrote “VAVAVA” in fontspaces preview box and copied it into UC. There is no invisible characters between letters. (If I understood correctly what I was supposed to do…)


How exactly do you test the font? Are you avoiding a font cache problem? Read this please: Eliminating font cache problems | Glyphs

I uploaded the new font to FontSpace, as FontSpace is the only place where the kerning doesn’t work. I can simultaniously see the old one and the new one, so I know the new one isn’t working either. I also think that the fonts are not rendered on browser, because all the preview texts are images. So it can’t really be a caching problem.

If you would like to take a closer look yourself, here are couple of links:

  1. This font is created with FontForge, and its kerning is working properly on FontSpace.

  2. This font is created with Glyphs, and it’s one of the problematic ones.

You can verify the kerning working/not working by trying a sample text “VAV”.

Sounds like buggy OpenType support, similar to PowerPoint. How does FontSpace create the images?

If they use a buggy or outdated renderer, you can try the Kern Flattener script to downgrade your font so it meets their standards. But much better if FontSpace updates the way they create their images.

It sounds like I’m better not downgrading my fonts. I have no idea what kind of renderer they are using, as I’m just a user of the site.

The FontForge-created font has no group kerning, and a single GPOS lookup. You have three options:

  1. Downgrade your font with Kern Flattener to shoehorn it into the requirements of software that does not fully support OpenType. It will break the kerning in (a copy of) your font, but make it more compatible.
  2. Try the Keep Kerning in one Lookup custom parameter in Font Info. Perhaps that suffices.
  3. Tell the people at FontSpace that you discovered a potential bug in their renderer.

That actually solved the problem! Thank you! Is there a downside of using it?

1 Like

It might increase or decrease the file size a bit. And in lead to a subtable overflow. But if the export was successful, you should be fine.

1 Like