I’ve looked through the manual and I understand how to set glyph-specific kerning, and kerning groups, so the kerning looks fine when I type something up within Glyphs. When I export the font and install it in Font Book, though (I’m running the latest version of Lion), the kerning only works when I use the font within InDesign; in any other program, like Word or Pages, it doesn’t work at all. Does anyone know why this would be?


The System is very easily confused if you install a new version of the same font.
Can you try to use another font name or clean the font caches and restart.

Thank you for taking the time to respond. Unfortunately, I’ve tried both your suggestions, but the glyph-specific kerning still only works in InDesign.

Can you send me the .glyphs file and the .otf. Then I have a look.

Now we now have a bigger problem: since the update released today, Glyphs crashes whenever I try to open my font (Ancillary.glyphs). I’ve just sent you the problem report, with my email address displayed. So I can send you the .glyphs file as I have it and the .otf file as I last exported it, but they aren’t exactly the same. (I’m still working on the font, of course, and it’s very much a work in progress; this is my first one, and I’m just sort of figuring typography out as I go along.)

What version (Glyphs and MacOSX) do you have now?

I have Glyphs 1.2.4 and Mac OS X 10.7.3 (Lion). When I open Glyphs and choose “check for updates,” it tells me that it is up to date.

Please try again. I fixed the update server.

Thank you, now Glyphs updated and no longer crashes.

I’m still left with the original problem, though: do you know how I could get kerning to work in programs besides InDesign? Like I said, I’ve already tried uninstalling the font, clearing the font cache, and reinstalling it, but that didn’t do the trick.

This seems to be a issue with Snow Leopard. The font you send me works fine in Lion.

To fix this, you need to add at least one OpenType feature. Add a f_i ligature and regenerate the features.

Like I said, I have Lion. Anyway, I’ve added an f_i ligature, deleted the font, cleared the cache, reinstalled the font, and kerning still only works in InDesign.

Did you actually generate the feature in Font Info > Features. Click the small circle arrow button in the lower left.