Lam alef ligature

I’m having problems with my lam alef ligatures.
I generated all the lam_alef glyphs from the arabic language bar, so I figured the ligatures would be automatically done, but when I use the type tool, my lam and alef stay the same and are not replaced by the lam_alef glyph. So what is the problem?
I tried going into the features tab and generating the dlig or liga for lam_alef like they said here but it didn’t work either. Could it be because I am on a trial version of the app? (wanted to try it before buying because I’m a student).
Also, when I’m in type mode, I tried clicking on Features on the left bottom corner but it doesn’t want to click…
Thank you!

After adding the glyphs, you need to press the update button in the feature tab in font info.
And did you name the glyph ‘lam_alef’? It should be ‘lam_alef-ar’.

Oh waw I wasn’t expecting you to answer out of all people, thank you!
I figured it out, I clicked on the arrow next to the glyph’s name and it said it’s because the app isn’t installed (it’s trial) which is also why it’s not showing up when I update my features…
Also it is lam_alef-ar as it is when I generate it, not changed.
Ps: you’ve made our lives much easier by including Arabic letterforms and other, thank you! Keep up the good work, I will try to buy the app when I can.

The arrow next to the glyph name is to see the glyph in another app called ‘Unicode Checker’. You need to install is yourself. That has nothing to do with the Trial version.

There are no limitations in the trial version. To enable the features in the lower left of the edit view you need to have some features and they need to be compiled. So click the ‘Update’ and the ‘Test’ button in Font Info > Features.

When I click on update in Font Info/Features, I get this

MakeOTF error
— Source font: font.pfa
bad CharString format

which brings us back to MakeOTF error when in Features tab

Sorry for the two posts confusion! I wasn’t sure the two problems were related…