Layered font: Metrics = OK... Optical = Not OK in InDesign

Making a layered font, with 5 masters, following this article

The masters all have the same metrics (Link Metrics With First Master checked) and in Glyphsapp and InDesign it looks OK.
But, when I change the spacing in InDesign from Metrics to Optical, the layers are off. Even when I type a line of characters with no kerning at all (only spaced in Glyphsapp).
Any tips on how to fix this?

Then don’t set it to optical. It will calculate a new spacing based on the shape of the glyphs and as those are different between the different layers, it will get a different result for each layer.

Thank you. The side-bearings + glyph width are exactly the same for all masters. The kerning is exactly the same for all masters. So I did not expect the layers to be off…

As I said, setting the spacing to ‘Optical’ in Indesign, ignores all metrics in the font. You have to keep it at 'Metrics`

1 Like

I hoped there was a workaround, because this could confuse the users of this layered font.
Thanks a lot for the quick answer!!