Ligatures and Vowel Marks

Hey! I have an issue which I’m sure is possible to be resolved, yet I cannot seem to find any solution by myself.

In my writing system, vowels are written as marks above the letter. For example, ca would look like c with a dot above it. The same goes for ligatures: ch is a ligature and to write an a after that, you should put a dot directly above it. On the other hand, cah would be written as c with a dot and an h glyph following.

Now, I have two problems:

  1. In “CHA” the mark does not attach to the anchor. I understand it expects a second anchor and if I put it there, the second problem appears:
  2. The ligature should not be separable by a mark. I want to be able to add a mark only after the ligature, and if the text reads CAH there should be no ligature at all.

I am attaching a picture of the current situation (in red) and my goal (in green). CA looks as it should. CHA does not work, since there is only one anchor above the CH ligature. The CAH should not look like this at all.

I would gladly accept any tips and directions, I’ve been trying to do this for a week now. I managed to do this long time ago in FontForge but I don’t know how to replicate it in Glyphs.

The Cha is more like a Conjunct in Indic scripts. For Ligatures to get marks, you need one top (top_1, top_2 …) and one bottom (bottom_1, bottom_2 …) anchor for each character that makes up the ligature. So setting the subCategory of the Cha to Conjunct or just leave it empty should fix it.

Thanks! I can’t find the Conjunct subcategory. Should I be able to find it in the glyph info under subcategories?

Just type/post “Conjunct” into the text field.

Thank you, it works inside the app! It disappears after exporting, though (It shows as a C + H + A instead of CH + A). What should I do to be able to see it in word processors?

How are you testing your font? Does it work on

I did, it has the same problem (CAH = CHA).

I’m attaching the project file since I worry it’s difficult to understand me.
Kajarte2303242.glyphs (467.8 KB)

Can you also send the document or at least the text that you use for testing?

I don’t have any, I just type random stuff. Here’s the text I used the last time:

Czasem cazier czym cyzma.

Is this what you expect?
Bildschirmfoto 2024-03-24 um 13.30.24

If so, you need to remove the first line in the liga feature. Otherwise it works just fine for me.

1 Like

Thank you! It works!