Line spacing issues


I have run into an issue because I have had to raise my Ascender height quite a lot in order to stop clipping with my diacritics. But now the line gap is quite large and doesn’t seem right . The line spacing tutorial seems to address several different types of line spacing but I am not sure how too apply this

how do I now change the set line gap to account for my extremely high ascender height?


Just to show as an example of this - this is a screenshot of my italic version at 9 points with 13 leading . the gap should not be this big but I can’t seem to close it


winAscent and winDescent values determine what is clipped and what is not. The vertical metrics should be set with the Custom Parameters. Just apply the Webfont strategy from the tutorial: Vertical metrics | Glyphs

Also, you can solve this by installing mekkablue scripts. In the mekkablue scripts, you will find Font Info > Vertical Metrics Manager and Test > Report Highest and Lowest Glyphs. Just accept whatever the Vertical Metrics Manager offers and then take a look in Font Info to get the idea how it works.

But read the tutorial first.

You cannot control line gap for Adobe apps, only the offset of the first line in a text box. All subsequent line distance info is set by the user.

In the screenshot, you do not see merely two lines, but a paragraph break. I’d check your full paragraph settings in the Adobe app.

You could be right. He might have adjusted Paragraph > Space before paragraph in Illustrator.

brilliant many thanks for you response !