Lnum feature is wrongly auto-generated

Hey, guys!

This only happened to me in one font and I know how to fix it manually, but it’s driving me crazy because I don’t why it’s going on.

I have a font with three sets of figures: oldstyle, lining, and tabular. I placed components of the oldstyle figures in the default figures. I generate automatically the OpenType features and the weird thing is that the lnum feature is wrong:

The oldstyle figures are replaced by the lining figures (ok!) but the default figures are replaced by the tabular figures (wtf?). Am I missing something?


Glyphs measures the width of the default figures to determine what substitutions are needed.

Adding components of osf to defaults seem to confuse this. Why not put the osf as default and remove .osf glyphs?

Thanks, @GeorgSeifert. Yeah, I’ve tried it before and the result was even worse—it’s like lining figures doesn’t exist. I am attaching a screenshot:

can you send me the .glyphs file?

Not necessary, @GeorgSeifert. I deleted the .osf glyphs (in the previous test I just marked them as ‘not export’) and now it works. Sorry. :pensive: