Make ssXX feature standard, easy way?

What’s the easiest way to make a ssXX feature with around 100 glyphs the standard? It’s also important that it respects kerning…

Find and replace the Suffix with an empty string. If necessary, rename the previous default glyphs first: find and replace empty string with an arbitrary suffix.

Kerning classes stay with the glyphs and singleton kerning will be changed to the new names.

Or do you mean on export for a certain instances? Then you can use a rename parameter.

this is basically how I did it now. I thought, there might be an easier way or maybe even a script for that. I have a swap glyph script that does this for one single glyph. A group swapping script could be very handy

at first, I thought I might set up two classes and on export tell glyphs to replace one with the other. Could this actually work?

It is not done with classes but with a rename custom parameter. Read the handbook about them.

I’ve used this before, but in the end I figured it to be much faster to do the search/replace thing

If you use the custom parameter, you can use the stylistic set as such in one instance and have it backed in in another.

In my case, I have to replace the feature for all the instances, for example for webfonts…

But that keep the .ssXX glyphs as they are for the desktop fonts and duplicate the instances for the webfonts. You could even use a .glyphsProject file for this.

on a sidenote: I just found, that the script for swaping glyphs isn’t working anymore in GL 2.3. Any ideas?

#MenuTitle: Swap Glyphs
# -*- coding: utf-8 -*-
Swap 2 selected characters

Doc = Glyphs.currentDocument
Font = Glyphs.font
Selection = Font.selectedLayers

listOfGlyphNames = [ for x in Selection ]

if len(listOfGlyphNames) == 2:
    Selection[1] = "Temp"

    print listOfGlyphNames
    Selection[0] = listOfGlyphNames[1]
    Selection[1] = listOfGlyphNames[0]
    from robofab.interface.all.dialogs import Message
    Message("Select only TWO glyphs")

Font.selectedLayers does not work anymore for two glyphs selected in Font view.

Ah, ok. How to fix this?

I fixed it.