MakeOTF error [internal] label not found


If I click the Update in the Features I get the following warning in a modal

MakeOTF error [internal] label not found

What does this mean

You probably have a glyphs name that contains a none ascii character in it.

What would be a none ascii character

Is there a way to search to find this

This tutorial might help: Troubleshooting a Font that Does not Export | Glyphs

Switch the search field to Regex mode:

And search for [^a-zA-Z0-9._\-]

Thank you , the search bought back bracketleft

but that should be ok shouldn’t

Is the glyph named bracketleft or [ ?

Its named ‘bracketleft’

Looks OK to me. Maybe there are some invisible/zero width Unicode characters hidden in the glyph name?

Click the glyph name, select the entire text, and replace it by typing bracketleft. That should remove any hidden Unicode characters.

Is this the only glyph that shows up when performing the search?

Yeah, I tried that but it still shows up in the search

This is the only character that shows in the search

Can you send us the file?

I think Ive fixed it now

I deleted all features and then re did them with ‘update’