MakeOTF error, that I do not know what to do with

Okay so, when I try to eksport my font I get a “MakeOTF error” with a long list of information, that I am honestly really quite bewildered by. At this point I have disabled evrything in font info> features, and thats the only way I have managed to export. Before this I tried both updating and compiling.
But something tells me that disableing and then exporting, this is not the right way to go about it.

I am very confused by “… in feature line file at line 49”. Is that in the code that appears in fontinfo>features? because in that case I don’t see any line like that.

Check the Features in font info. There is some feature code that has references to glyphs that are not in the font.

Seems like you edited an existing font. Read this please:

@mekkablue I have read through the article, thanks! As far as I can tell the problem is still in the feature file.
At this point when I go to Font info> Features I have checked the boxes “Generate feature automatically” as well as “disabled”, under Classes>Uppercase and Features>cpsp Capital Spacing. When i click update I still recieve a message, but this time, much shorter, I’ve attached a screenshot

. When I click on “Details” Finder pops up, and takes me to a temp folder. Under the feature.fea file, I have found some code, that kind makes sense, with the message, that pops up in the box. Does it seem right to you guys to edit these files, that show up under “Temp”?

I just tried editing the feature.fea files, and still the message pops up, when I try to export

The error message says that Ldot is not in the font. That means: the OpenType feature code is referencing a glyph name (Ldot) that does not exist in your font. In other words, there is no glyph called Ldot in the font you are trying to export.

Two possibilities:

  1. the glyph is there, but has a different name because the font you opened does not adhere to the naming scheme the code expects. In that case, update the glyph names. This is explained in the tutorial.
  2. the glyph is just not there and the feature code is simply wrong. Then you need to update the feature code. You can delete the features in File > Font Info > Features, or set the affected features to automatic, or edit the code manually, whatever you prefer.