Mark Fromberg plugins not working

I searched a bit on the forum, but couldn’t find anything on it. I’ve been trying to install Mark Fromberg’s plugins “show rotated” & “show siblings,” and no matter how many times I install, restart, redownload, they will not show up in the view menu.

I have Speedpunk installed, and it is working fine. I’m on the latest version of Glyphs as well.

I wanted to check here before contacting Mark to see if there was any fixes I could apply.


There are some troubles with the plugin architecture in the very latest beta version. As a workaround, you can downgrade or wait for the upcoming beta.

I changed some things very recently, though they worked for me. Trying to keep pace with the architecture of the newest Glyphs versions. Feel free to hit me with a PM here, maybe we can figure out the problem with some console logs of yours. Which Glyphs Version do you have?

Do you have version 2.2.2 or 2.3beta?

I’m running 2.2.2 currently. I’m not in any sort of rush to get them working, so I can wait for the next Glyphs release, I was just excited to use them! I’ll PM you if you’d like me to send you the log report so you can troubleshoot.


Sometimes the console log for a plugins say sth like this, which nevertheless seem to work though:
Plugin loading: Problme with plugin at path: /Users/.../Library/Application Support/Glyphs/Plugins/Aliases/ShowPathMeasles.glyphsReporter

BTW: there is a typo in the console log: »Problme« :slight_smile:

Any chance to get more info squeezed out of the console in such cases?

When something goes wrong, there usually is also another entry in the console, shortly before, that even points you to the line number in

Right, i found one entry and the cause.
Still wondering why this particular plugin just generates this one line, nothing else, but also works fine in Glyphs.

Hi, I’m having the same old issue. Tried to install the siblings plugin but it doesn’t appear in the View-menu. It does show up in the plugins folder.

I have version 2.4

Thanks for helping :slight_smile:

Oh ps. Awesome work in general with Glyphs. I’m currently in process of moving back to Glyphs from RoboFont :smiley:

You did restart after installing it from the Plugin Manager, right?

It works in 2.4.1, perhaps there was a bug that was fixed in the recent betas. There is only one glitch, in the menu it says Show Show Siblings.

Yes I restarted Glyphs a bunch of times.

Can you try the latest beta version?
Enable Cutting Edge in Glyphs > Preferences > Updates and then check for updates.

That’s weird, it still doesn’t work even after updating to 2.4.1

@mekkablue you have the same version and the plugin works right?

Yes, except for the menu name glitch:

I made a pull request in Mark’s GitHub repo, which should fix this.

  1. Is there nothing in the when you start Glyphs?
  2. Can you try emptying the Plugins folder (perhaps there is a conflict?), reinstalling the plug-in, restarting the app?

I tried that too and it still doesn’t show up.

I hope the pull request helps :slight_smile:

Thanks for helping!

  1. No message in the Console?
  2. Is Vanilla installed? Click the Glyphs > Preferences > Addons > Modules > Install Modules button, restart.

Hey yes that did the trick! Didn’t know I had to do that.

Thanks a lot!

It is missing in the readme. I’ll make a pull request :slight_smile: