Mekkablue, steal kerning from indesign authorization problem


#1

Dear Mekkablue,

I was trying to run steal kerning from InDesign script, but I receive this message on Macro panel. I decided to add permissions to Glyphs from security and privacy panel on Mojave, but I received the same output. I am using 2015 Indesign.

Thank you for your wonderful work and support :muscle:

Error output:

Accessing: Adobe InDesign CC 2015
AppleScript Error:
{
NSAppleScriptErrorAppName = “Adobe InDesign CC 2015”;
NSAppleScriptErrorBriefMessage = “Not authorized to send Apple events to Adobe InDesign CC 2015.”;
NSAppleScriptErrorMessage = “Not authorized to send Apple events to Adobe InDesign CC 2015.”;
NSAppleScriptErrorNumber = “-1743”;
NSAppleScriptErrorRange = “NSRange: {55, 16}”;
}
Tried to run:
001
002 tell application “Adobe InDesign CC 2015”
003 tell front document
004 name
005 end tell
006 end tell
Traceback (most recent call last):
File “”, line 112, in
AttributeError: ‘bool’ object has no attribute ‘strip’


#2

It works for me, but I also have the respective permissions set in System Preferences > Security & Privacy > Privacy > Automation > Glyphs.app. I never set them consciously though. I suppose at one point I must have confirmed a dialog.


#3

Thats interesting, there is no option to add a specific application to Automation tab. I will try to install Xcode. There might be an option to add it via Xcode. The weird thing is, the system doesn’t show a notification like ‘do you allow this application to control the other application’ when I call the code. I will update you when I find a solution.

Thank you Mekkablue :slight_smile:


#4

I have found a Terminal script

osascript -e ‘tell application “Glyphs”’ -e ‘set _b to bounds of window of desktop’ -e ‘end tell’

When I run this script a dialogue shows up and lets me add finder to Automation. Is it possible to do the same with Glyphs?


#5

just replace Finder with Glyphs doesn’t do anything? You might need to write a AppleScript that works in Glyphs.


#6

I used this terminal code but it added glyphs as a sub category under Terminal. I will install High Sierra until I find a solution. I will update you later :face_with_monocle:

osascript -e ‘tell app “Glyphs” to display dialog “woop woop”’


#7

Hi guys, I got exactly the same error and message, how can I fix it ? Thanks !


#8

Make sure the respective checkbox in System Preferences > Security & Privacy > Privacy > Automation > Glyphs.app is on:


#9

Thanks for your help. Unfortunately I don’t have the Glyphs app in the automation list, and I have no idea how I can add it


#10

Btw I’m on Mojave
Tell me if there’s a solution


#11

When you run it, there ought to be a dialog that asks for confirmation. Perhaps it is covered by another window.

Confirming that dialog adds the Glyphs entry in System Preferences.


#12

I’ve been looking for a dialog window but unfortunately I have nothing. I think I did all the steps. Indesign with one page and one text box sets in Optical. Then I run the script in Glyphs and I have this output :

Accessing: Adobe InDesign CC 2019
AppleScript Error:
{
NSAppleScriptErrorAppName = “Adobe InDesign CC 2019”;
NSAppleScriptErrorBriefMessage = “Non autoris\U00e9 \U00e0 envoyer des \U00e9v\U00e9nements Apple \U00e0 Adobe InDesign CC 2019.”;
NSAppleScriptErrorMessage = “Non autoris\U00e9 \U00e0 envoyer des \U00e9v\U00e9nements Apple \U00e0 Adobe InDesign CC 2019.”;
NSAppleScriptErrorNumber = “-1743”;
NSAppleScriptErrorRange = “NSRange: {55, 16}”;
}
Tried to run:
001
002 tell application “Adobe InDesign CC 2019”
003 tell front document
004 name
005 end tell
006 end tell
Traceback (most recent call last):
File “”, line 112, in
AttributeError: ‘bool’ object has no attribute ‘strip’

Tell me if I miss anything


#13


#14

I’ve been looking all day for something, couldn’t find a way to make it work, and no dialog box at all


#15

Every time I am trying to automate something, I get that dialogue. Perhaps you have a more restrictive security setting in System Preferences?


#16

I don’t think so, I unlocked the settings in the preferences. Here’s is what I have when I try to use the script. Are running the script through another app or directly on Glyphs ?


#17

I also tried with the settings on “App Store and identified developers”


#18

I am sorry, your Mac does not allow the script to interact with InDesign. Some googling brought this up: https://stackoverflow.com/questions/51299066/macos-mojave-automator-not-authorized-to-send-apple-events-to-system-events

Maybe this helps you? Perhaps you need to uninstall and reinstall Glyphs to trigger the dialog again.


#19

What version of Glyphs do you have?


#20

Current script works well here with Glyphs 2.6.1 under OS 10.13.2. But have no Automation tab in Privacy section in System prefs you all are talking about