Mekkablue, steal kerning from indesign authorization problem


#1

Dear Mekkablue,

I was trying to run steal kerning from InDesign script, but I receive this message on Macro panel. I decided to add permissions to Glyphs from security and privacy panel on Mojave, but I received the same output. I am using 2015 Indesign.

Thank you for your wonderful work and support :muscle:

Error output:

Accessing: Adobe InDesign CC 2015
AppleScript Error:
{
NSAppleScriptErrorAppName = “Adobe InDesign CC 2015”;
NSAppleScriptErrorBriefMessage = “Not authorized to send Apple events to Adobe InDesign CC 2015.”;
NSAppleScriptErrorMessage = “Not authorized to send Apple events to Adobe InDesign CC 2015.”;
NSAppleScriptErrorNumber = “-1743”;
NSAppleScriptErrorRange = “NSRange: {55, 16}”;
}
Tried to run:
001
002 tell application “Adobe InDesign CC 2015”
003 tell front document
004 name
005 end tell
006 end tell
Traceback (most recent call last):
File “”, line 112, in
AttributeError: ‘bool’ object has no attribute ‘strip’


#2

It works for me, but I also have the respective permissions set in System Preferences > Security & Privacy > Privacy > Automation > Glyphs.app. I never set them consciously though. I suppose at one point I must have confirmed a dialog.


#3

Thats interesting, there is no option to add a specific application to Automation tab. I will try to install Xcode. There might be an option to add it via Xcode. The weird thing is, the system doesn’t show a notification like ‘do you allow this application to control the other application’ when I call the code. I will update you when I find a solution.

Thank you Mekkablue :slight_smile:


#4

I have found a Terminal script

osascript -e ‘tell application “Glyphs”’ -e ‘set _b to bounds of window of desktop’ -e ‘end tell’

When I run this script a dialogue shows up and lets me add finder to Automation. Is it possible to do the same with Glyphs?


#5

just replace Finder with Glyphs doesn’t do anything? You might need to write a AppleScript that works in Glyphs.


#6

I used this terminal code but it added glyphs as a sub category under Terminal. I will install High Sierra until I find a solution. I will update you later :face_with_monocle:

osascript -e ‘tell app “Glyphs” to display dialog “woop woop”’