Metric key annoyance

If I copy a glyph name to paste in the metric key, it copies the whole name, but when I go and prepare to write the equation for example “=|guillemotright”, what happens is i type “=|” and then paste “guillemotright” but it becomes “=| guilsinglleft” with a space and then I hit enter and it becomes “=|” instead…

You can disable it from the context menu under Substitution > Smart Copy/Paste. But I changed it to be off by default.