Metric keys seem to have a length limit

Adding a metric key like =lineIntegrationWithSemicircularPathAroundPole truncates the last character and becomes =lineIntegrationWithSemicircularPathAroundPol, and it is not only the display, since Glyphs does not recognize the glyph name and no metric syncing happens.

I increased the max length a bit.

Be we should shorten those names a bit, e.g. I usually take out the “with”.

Sounds good.

Here are the names I came up with:

    <glyph name="dblintegral" unicode="222C" production="uni222C" />
    <glyph name="tripleintegral" unicode="222D" production="uni222D" />
    <glyph name="quadrupleintegral" unicode="2A0C" production="uni2A0C" />
    <glyph name="contourintegral" unicode="222E" production="uni222E" />
    <glyph name="surfaceintegral" unicode="222F" production="uni222F" />
    <glyph name="volumeintegral" unicode="2230" production="uni2230" />
    <glyph name="clockwiseintegral" unicode="2231" production="uni2231" />
    <glyph name="clockwisecontourintegral" unicode="2232" production="uni2232" />
    <glyph name="anticlockwisecontourintegral" unicode="2233" production="uni2233" />
    <glyph name="finitePartIntegral" unicode="2A0D" production="uni2A0D" />
    <glyph name="doublestrokeintegral" unicode="2A0E" production="uni2A0E" />
    <glyph name="slashintegral" unicode="2A0F" production="uni2A0F" />
    <glyph name="circulationfunction" unicode="2A10" production="uni2A10" />
    <glyph name="anticlockwiseintegral" unicode="2A11" production="uni2A11" />
    <glyph name="rectangularlineintegral" unicode="2A12" production="uni2A12" />
    <glyph name="semicircularlineintegral" unicode="2A13" production="uni2A13" />
    <glyph name="nopolelineintegral" unicode="2A14" production="uni2A14" />
    <glyph name="pointoperatorintegral" unicode="2A15" production="uni2A15" />
    <glyph name="quaternionintegral" unicode="2A16" production="uni2A16" />
    <glyph name="leftarrowhookintegral" unicode="2A17" production="uni2A17" />
    <glyph name="timesintegral" unicode="2A18" production="uni2A18" />
    <glyph name="intersectionintegral" unicode="2A19" production="uni2A19" />
    <glyph name="unionintegral" unicode="2A1A" production="uni2A1A" />
    <glyph name="overbarintegral" unicode="2A1B" production="uni2A1B" />
    <glyph name="underbarintegral" unicode="2A1C" production="uni2A1C" />
    <glyph name="summationintegral" unicode="2A0B" production="uni2A0B" />

Thanks. I could see that camelCase could improve readability?
And would it make sense to call them “integralSurface”, “integralVolume”? (Like I renamed “dotlessi” to “idottless”) That would make harder to discern the glyphs from that list, but easier to differentiate them from all other glyphs?

I’m not very attached to these names, it was a quick job to get things going. I’m not a fan of camelCase either, and it is telling. I tried also starting all the names with integral but it sounded silly. But whatever works for you is fine.

I found some other obscenely long names, like measuredAngleWithOpenArmEndingInArrowPointingDownAndLeft, but I left them for now.