Migration to M3 went wrong

Hi Georg,

I just migrated to a new M3 mbp. I am facing the following issues:

Glyphs2. When I opened my G2 version I was prompted to manually install Python2 and after doing it the app is just hanging on start (icon bounding and nothing is happening).

Glyphs3.1.2 (3151). It starts with a message of all previously installed plugins failing and removing and reinstalling them does practically nothing because it is refusing to Install Python Runtime. Every time I am going through the “Are you sure you want to install the Python module” nothing happens after I press OK. The plugin shows as installed in the plugin manager but I don’t see any scripts in the list or filters that are supposed to be installed. After some time I got the message:

Failed to clone repository from
GitHub - schriftgestalt/GlyphsPythonPlugin: Python runtime packaged as a plugin for Glyphs
/Users/kostas/Library/Application Support/Glyphs 3/Repositories/GlyphsPythonPlugin

I also tried the Troubleshooting from this page : Extending Glyphs | Glyphs but nothing worked.

I would really appreciate it if I didn’t have to do a clean install because there are many things that are customized in both G2 and G3.

For glyphs 2) have you also installed pyobjc? Details here: Glyphs 2 on Monterey | Glyphs

For Glyphs 3)Try removing the Repositories folder and install python from the Plugin Manager, not from the Script menu.


Both fixes worked. Thanks so much. I hope G2 keeps working. It runs but I didn’t work on it yet.

Glyphs 3: on M3 Macs, Python does not install in the Plugin Manager currently. Until this is fixed, follow the installation instructions for ‘your own Python installation’ in the Extending Glyphs tutorial.