Misc. minor bugs and suggestions

These are all based on v1.44 (598), OS X v10.9.4.


  1. If you start Glyphs, open a project and immediately try to print you’ll print a screenshot of the app’s window. This is also true if you switch to column view. If you select a glyph and then print, the correct print layout appears. This is also true of column view. If you unselect that glyph the correct print view remains in place.

  2. In the print dialog, the checkboxes for the Glyphs specific options are sometimes not visible. Sometimes some are, some not. Sometimes all are not visible. If you click in the place the should be, they appear. Couldn’t reproduce it consistently but it’s common.

  3. If, in column view, you first switch the sort order to e.g. sub-category ascending, and then turn off the export checkbox of several glyphs (say, over 20), the previously selected sort order gets lost. I don’t know what the cutoff point is but it happens consistently if you select enough glyphs and turn off export.

  4. If, in column view, if you change the sort order to e.g. Unicode ascending, then close the project and app and open the app and project again, your previous sort order will still be in place, but only in column view. Icon view will default back to sort by ID.

  5. If you select some glyphs, then go to Add List Filter, then when the dialog box comes up, press Cancel, the new list filter gets created anyway.

  6. You can’t copy/paste glyphs based on CID encodings into a list filter and use these as the basis of your filter but you can with Latin characters. It’d be even nicer if characters pasted into the list filter would already appear one under the under.

  7. When printing, I don’t think the glyph name/ID font scales with the number of columns selected. If it got a little smaller when more columns are selected there’d be a better chance of being able to see the entire glyph name/ID printed under each glyph.

  8. The glyphs search field is not picking up the unicode names for (some?) CJK glyphs. For example, the following name based searches don’t work: radical, kangxi, eye, fire etc.

  9. I’m a little unsure about this but should ideographs be grouped under Chinese (instead of a more inclusive term such as CJKV)? Many are used in e.g. Japanese as well. Similarly, should kana be under Japanese? I know they’re Japanese but AFAIK they are included in some Chinese specific character sets as well.


  1. I really like using the filter function. But as a result, I often find myself changing the list of glyphs in a filter or changing the filter’s name. It’d be nice if I could right-click on the filter to get a context menu to edit, delete or rename a filter.

  2. When in the icon or column based glyph overview/default view, it’d be nice if I could print out only the currently selected glyphs.

  3. It’d be super nice if I could paste an actual character into the glyphs search field instead of having to use its unicode code or CID code. That would save many round-trips to the OSX character palette or a similar resource when searching for CJK ideographs. Or is there a better way?

2. When in the icon or column based glyph overview/default view, it’d be nice if I could print out only the currently selected glyphs.

Though it may not be exactly the kind of display you need, one option would be Cmd-T, Cmd-P. (Cmd-T opens a new editing tab with the selected glyphs.)

Thanks for reporting, we will have a look.

You can convert a character to a glyph name with a service: www.glyphsapp.com/tutorials/system-services
That's a good tip. Thanks! I had forgotten about this - it sorta works in my case. Since I'm dealing with a CJKV font (Source Han Sans) which uses CID encoding, if I select for example the first few Kangxi radicals ⼀⼁⼂⼃⼄⼅ and convert to Glyph names, I get /uni2F00/uni2F01/uni2F02/uni2F03/uni2F04/uni2F05. Fine and well, but if I then copy/paste this into a new Glyphs filter I get no matches, presumably because the uni2F00 etc. is only the mapping not the primary encoding. What I really needed here was cid09831/cid09885/cid09907/cid09920/cid09961/cid10025. One additional Vermuthstropfen.. PUA glyphs get converted to /(null)/.

BTW, if after converting to e.g. glyph names using these services, the glyph name was also copied to the clipboard, I could save one more step.

fixed it This seems to be a issue like the disappearing values in some filter dialogs. But I can't reproduce it. This seems to be an issue with the table view. I will have a look but I'm not sure I can fix this. This is related to number 3). So the same chance that I can fix it. fixed it That should work. you need to use the names of the glyphs (cid12345). the glyph search field will pick up the names of the glyphs in the font. So if you have a glyph thats name contains search term it will show up. The ideographs are all of Chinese origin even if they are used in other languages. It is kind of like with the latin letters used in other European languages. I will add that. You can double click to edit the filter, slow double click to change the name. fixed that added that

Wow. Now I almost feel guilty! It’s great to see these items addressed so quickly. I was especially pleased to see this:

Thank you.