Moving the glyphs using Transformations Custom Parameter

Hi again.
I’m stuck with a simple idea : moving my glyphs downward a little bit.
I try to use the Transformations Custom Parameter, but whatever I did, I’ve never succeeded…

Here is the whole line for the code :
Transformations; LSB: ±‌shift*; RSB: ±shift*; Width: ±shift; ScaleX: percent; ScaleY: percent; Slant: degrees; SlantCorrection: bool; OffsetX: amount; OffsetY: amount; Origin: select

First, I would like to know what LSB and RSB means ?
Then, do I have to fill all thoses options, or could I just write the one I’m interested in ?
I just typed this :
Transformations; OffsetY: -20;
But there is no change at all on the exported OTF file.

Could you please help me ?

  1. Type a few glyphs into an edit view tab
  2. Select them with the Text tool
  3. Run the filter from the pulldown menus
  4. Instead of applying it, click on the gear :gear: button in the lower left hand corner of the dialog, and choose copy custom parameter. The parameter info is now in your clipboard.
  5. Cancel out of the dialog.
  6. Open font info, go to the instances/exports tab, and paste the custom parameter into one of the instances.

LSB and RSB are the left and right side bearings. Please read the tutorial called Spacing.

Thanks @mekkablue.
It seems logic for you :smile: but really “Developper-oriented” for me !

When I copy the custom parameter from the pulldown menu, here is what I’ve got :

{
customParameters = (
{
name = Filter;
value = "Transformations;OffsetY:-20;Origin:0;";
}
);
}

I assume that I only have to use this part :

Transformations;OffsetY:-20;Origin:0;

But when I paste this part in a filter Custom Parameter into my instance, nothing still happens… :sob: (and no error during export)

After copying from the filter dialog, jut go to the instance settings and paste (you might need to click into the right side of the view to make sure the focus is set correctly. So no need to paste the full code and make your own filter entry.

Thanks @GeorgSeifert, it works, indeed.
But it does exactly the same thing that I did by myself : creating a custom parameter with the same code. Granted, it is easier, but guess what ? The result is the same too ! :weary:
It seems that this parameter is completely ignored by the export engine…
Did you test it in the G3 app ?

It works fine for me.
this produces a font where the uppercase sit on a -144 baseline:


You are right, @GeorgSeifert, my font is indeed below the baseline !
I’ve just discovered that I only tested the OTF file in Photoshop and Illustrator, but everything’s fine in InDesign !
Do you know where it could come from ? Why Photoshop & Illustrator ignore the transformation ?

It might be that you are looking at an old version of the file. How are you testing (https://glyphsapp.com/learn/testing-your-fonts-in-adobe-apps)
Make some obvious changes to a glyph and export again and check if that change shows up in those apps.

It could have been an old file @GeorgSeifert.
But I faced font cache issues some time ago, so now I only work with the Adobe Fonts Floder !

I tested with other obvious changes and they are clearly visible in any app (InDesign, Illustrator & Photoshop)
But the OffsetY change only appears in InDesign ! :dizzy_face:

So I’ve investigated a little bit more : if I try to move the fonts to the left or right (using OffsetX instead of OffsetY) the result appears in all apps ! :grimacing:

Is there any reason why some apps don’t “read” the X value of the font ?

I think they do. It is just that you won’t see much of a difference if everything is moved left or right.

It seems that you misunderstood me, @mekkablue :
I see the changes when i move the font to the left or right using (OffsetX), but not when I move it upward/downward (using OffsetY)
So the problem appears only with OffstY in Illustrator & Photoshop !

I answered your question in the other thread. And try to add a line break. You will see the difference in the second line.