New bugs

I’m your favourite beta tester :slight_smile:

  1. glyphs crashes often, maybe something linked with the new release. The is no specific pattern. It guess it happens when I close a glyph tab, switch on the main font window and double-click to open a new one. When I do it too fast, the app crashes.
    I’ve also noticed the app often crashes if I have activated the measure tool and I close the single glyph tab.

  2. The Dimensions window do not memorise the datas.

  3. Each time I open Glyphs I see the report bug window! And some glyph-tabs opens even If they haven’t benn opened last time I’ve edited the font.
    There is something wrong with the autosave mode or similar.

note: I’ve used the 04.4 version.


to 1) Many Thanks to pointing to the measurement tool. I could find this bug and fixed it. It didn’t had anything to do with speed. If you have the measurement tool selected and closed the tab, you have all time of the world to crash it if you open a new tab.

to 2) Did you save after adding the values? Unfortunately entering the values does not dirty the document, so you won’t be asked if you close the document.

to 3) The tabs are stored not on closing the font but save the document. So if you open a new tab or close one, and don’t save afterward it will show the setup from the last save.
The crash reporter only sends and deletes the last one. If you didn’t send some reports earlier, you will be see them over end over again unless you hit dismiss.

Hope that helps


  1. I’ve noticed the 2 cases, the first with the measure tool; the 2nd randomly when opening new glyphs quickly

  2. Yes I’ve saved. But the values disappear even if I change tab!

  3. I’ve tried anything: to discard, to post, to ignore. No changes, I’m always prompted. I’m going now to try delete the app with Appdelete (deletes app and prefs) and reinstall it again. It should fix the issue. For info, it started happening yesterday as I worked offline.

Update: I’ve sent you by email my prefs files before deleting them. Maybe you’ll find there any useful information?

opening a glyph fast, the app frozen. at reopening it, there was no debug window and my font file is screwed up! the import font action loop endlessly…
this is very annoying

Can you send me the file?

I discorvered what’s up! I opened the file in textEdit and I’ve erased the Feature {}
In fact, adding manually a ligature to the automatic generated list corrupts the file.
I’ll try to add it as a second features group

I just uploaded a new version with the fix for the crash you reported. Please have a look.

The document corruption is fixed for the next version. Thanks for reporting.

Great! thanks you for your excellent work!

“The update is improperly signed.”

I’m sorry, which bug have you fixed?
I experience all the bugs than before. The mix with automatic/manual fetaures corrupts the files (have to open them in text editor and erase the features {}; the “mesaure tool” bug persists too.

even if I disable the Automatic features generation, the file is corrupted on next opening.
In fact I cannot write manual ligatures at all.

If the file the corrupted, you can try to fix it in a TextEditor. Search for “features” and delete everything between the following parenthesis (until something like "fontMaster = ").