New Update - Glyphs 3 not working

I updated to the latest version of Glyphs (3.0.4) and when I try to open the program it doesn’t work - it just has the rainbow loading wheel cursor in the menu bar. I have the latest version of macOS. I’ve tried deleting and reinstalling Glyphs, but I run into the same program. I have also tried opening with option-shift with no luck.

1 Like

The previous version should be in the Trash. Or download it here:

But we should find out what’s causing it, so keep the new version around. When you run the old version, close all files and then try to open the new.

Hi, I opened the old and closed all files and tried to open the new and it was still giving me the same problem. How would I go about finding out what’s causing the issue? Thank you.

Please update to the latest cutting edge version. Activate it in Preferences >Updates.

I have installed the latest cutting edge version of Glyphs. It works, but when I start kerning, it becomes incredibly sluggish, does not respond and I get the spinning beach ball of death.

Sorry, my bad. I left too many options (view) on…

I just updated to the latest version but it’s giving me the same problem when I open the new version.