Newbie's problems generating variable fonts -- solved

I got Glyphs about three weeks ago, and I’ve been very happy with it. A week ago, I actually managed to export a variable font (one axis, two masters) that works!

But now I’m having problems. One file fails to export with the message:

*** -[__NSArrayM objectAtIndexedSubscript:]: index 4 beyond bounds [0 … 3]

Searching this forum, I’ve seen that when users have had this problem in the past you have asked to see the file. It is here:

This is the italic version of the font. I did manage to export the roman version–for a while. Now it produces a font with no error message, but Adobe Illustrator doesn’t recognize it as a font. It can be viewed in Font Book, but installation fails without an error message. TTX decompiles it sometimes, and sometimes reports an unknown file format. Glyphs opens it sometimes, and sometimes complains that there’s no name table. I’m guessing that there’s some inconsistency between masters that’s messing things up. Here’s the link for the roman:

I should mention that Glyphs produces the instances as TTF fonts perfectly.

Thanks for this great app, and for your help!

Can you try the latest cutting edge version? You need to activate it in Preferences > Updates.

Sorry–I should have mentioned that I installed that this afternoon (version 2.5.2 (1161)), and it did not change the situation.

Exports just fine for me and works in Illustrator perfectly fine and i have the latest cutting edge version as well.

Thanks for testing, dyb. Are there ever issues with different OS versions (I have 10.13.6 (17G65)), or other installed software (I have fonttools, an old version of AFDK, and ttfautohint installed separately)?

My OS is exactly the same. I don’t remember what other software i have installed and my python installations are a mess at the moment.

If you just need the exported version i can send it to you, though it would be best to get rid of the problem.

Thanks for the offer, but the font is still pretty raw and needs lots of revision and testing. So I’ve got to get it working. Tomorrow I may try uninstalling some of these redundant programs and making sure my Python installation is up to date.

This is probably a font cache problem. Read this please:
Are you using the Adobe Fonts folder?

Thanks, I will check out the cache post. Yes, I followed the instructions for setting up the Adobe fonts folder.

Please don’t mess with python yourself. If you have installed it manually, try to remove it or at least make sure Glyphs can use the systems default python. But that is not really relevant for this problem.

Clearing the font cache fixed the problem with the roman. (I’ll be paying more attention to the tutorials from now on!) The default version of Python in my system is 2.7.10. I have Python 3 installed as well: is this a problem?

I haven’t uninstalled AFDK or Fonttools but have removed them from my PATH. That makes no difference.

Where is the error message “[__NSArrayM objectAtIndexedSubscript:]: index 4 beyond bounds [0 … 3]” even coming from? Not a Python message, apparently.

That is a bug in Glyphs. It should be fixed in the latest cutting edge version.

I have the latest cutting edge version and am still having the problem. I’ll keep up to date and hope for the best.

Could you send me the file?

I had some old TT instruction stuff hanging around in the Font Info box. Deleted that and all was well. Thanks to Georg and all for the help.

I’m trying to use the Cutting edge version for variables, but I get a message while setting preferences that Glyphs cannot be updated because: “when it’s running from a read-only volume like a disk image or an optical drive. Move Glyphs to your Applications folder, relaunch it from there, and try again.”

It is in the apps folder and there is no other version of Glyphs on my machine.

Please copy the app into the Applications folder. You still have it in the Downloads folder.