No kerning in Office

Thanks for the answers.

We just finished a typeface family containing more than 800 glyphs and 4000 pairs in each weight – and kerning works just fine in both Office Word and Powerpoint. Even without adding the ‘Write Kern Table’ custom parameter.

However, now we are working on a small project containing only 265 glyphs + 245 pairs and all of a sudden kerning doesn’t work in Word and Powerpoint.

We are very curious to learn how and why kerning in OTF’s exported from Glyphs App sometimes work + sometimes doesn’t work. What can we do exactly to localise the bug? And how come the kerning works when exporting as a TTF?

We really like working in Glyphs and we can provide you the .glyphs file if that helps solving the problem?

I had a look at the fonts you sent us, exported both CFF and TTF versions, and both work fine in Word, including kerning.

The only things I changed:

  1. removed the Write kern Table parameters from Font Info > Instances,
  2. updated & recompiled the features in Font Info > Features,
  3. fixed the faulty standard stems in Font Info > Masters.

And of course, in Word, you are required to activate Kerning in the Font > Advanced dialog, here is a screenshot with the CFF version of your font:

Thanks again – much appreciated, mekkablue!
We did exactly as you say, and it still doesn’t work. Can you please send your updated glyphs-file to me. This is so weird : )

If you try to change a file and install it in the system, you run into font cache issues. Rename the font every time you export/install.

It is not a cache problem – we have changed the font name every time as well as tested the exported OTF’s on 2 different macs + 1 pc. We are sorry to keep on posting this issue.

I didn’t test this, but could this be related to this? Opentype Features - MS word

1 Like

The link from harbortype did the trick for us. We unchecked the ‘generate automatically’ check box in the Languagesystem prefix, and changed it from 'languagesystem DFLT dflt; ’ to ‘languagesystem latn dflt;’

So far it works. And thanks you for the support – very useful and quick.

1 Like

Sorry, I didn’t save the updated .glyphs file, but I am positive all the features were automated in my case.

I talked to @Eduilson, who discovered this bug on the other topic. Glyphs used to generate these lines automatically:

languagesystem DFLT dflt;
languagesystem latn dflt;

However, since a recent version (not sure which one), new files only get the first line.

3 Likes

@harbortype It did the trick : ) Thanks.

1 Like

Hi Torsten, did you get any wiser on this issue?

We are finishing a typeface. Kerning works in MS Word (after changing the Language system), but NOT in Power Point. Did you discover any other parameters that can effect this?

Thanks. /Nicolaj

PowerPoint does not support OpenType GPOS. You can try an oldstyle kern table. But generally, PowerPoint is pretty bad when it comes to supporting font technology.

Hi @mekkablue

I’ve tried installing other otf fonts on Windows e.g… Info from FontFont which has much more kerning pairs than ours. Kerning looks fine on Powerpoint - same with Hoeflers Gotham.

Tried the Write Kern Table Parameter, without result…

Did you check the Languagesystems in the features?

Yes, did that too. Works in MS Words. Not in PowerPoint. Pretty annoying :slight_smile:

Hi @nicolajbak,

Try to run it through Microsoft Font Validator http://www.microsoft.com/en-us/Typography/FontValidator.aspx

The test software only works on a PC.

It may give you some answers, but again as @mekkablue wrote, PowerPoint is very hard to handle when it comes to kerning, the logic is hard to find. Write Kern Table does the trick, sometimes. A handful of Microsofts own fonts does not work with kerning in PP, so…

Hi @RasmusLM,

Thanks, I will give it a shot! And yes: Soooo…!?

UPDATE:
I tried checking the font in FontValidator, but didn’t find anything alarming.

What font format are you testing, both .otf and .ttf?

For now, only otf

try .ttf

MS Office likes TrueType flavour better…